OpenJDK and eclipse[Solved]

The screenshot above shows the error that eclipse shows me when i am runing it. This error is only shown when i am i have OpenJDK installed. if i have Oracel JDK installed, eclipse runs fine. how best can i go over this problem?

Does the log file it suggests exist? If so, could you paste its contents into a pastebin or similar service?

I am not sure whether the log file exists or not. Actually, i don`t even know where to get the log file from

If you open the MyEclipseApp on your desktop, is there a file called “.log” in there?

no there is no .log file in MyEclipseApp

Hmmmmm… hard to diagnose an issue without any log. Perhaps someone else in the community will have come across something like this before.

thank you for the help @ibacher

Delete the .metadata folder from the workspace and start the eclipse. In case you have existing projects in the same workspace import them. Take note that .metadata folder is a hidden folder, do you mind finding out how to show hidden files on windows OS; take a look at

i have deleted the .metadata folder from MyEclipseApp folder and restarted eclipse but the error is still persistent.

@jnsereko , what version of ecclipse and openJDK are you running ?? Some versions of eclipse do not support certain versons of openJDK out of the box. You may have to add in specific plugins in your eclipse.

i am using openjdk version "12" 2019-03-19 and i am using Luna Eclipse-SR2-win32-x86_64-4.4.2

Luna Ecclipse is too old to be able to support openjdk 12 out of the box.

May be one question to ask , are you setting up that environment for OpenMRS development ??

i aready set up the environment as i was using oracle JDK

Alright , but for openjdk 12 , youll try some later versions of ecclipse say oxygen or phantom.

For OpenMRS development , it would be better you run on java 8

ok @mozzy let me try getting the oxygen or phantom version

thank you for the assistance

As we wait your progress over @mozzy’s idea, do you mind opening your eclipse in a new workspace rather than the previous one. I mean create a new workspace and choose that newly created workspace and open your eclipse, share your observation

@kdaud, i have tried starting eclipse witha new workplace but still eclipse fails to start

@jnsereko try downgrading to openjdk 8

ok let me try that

1 Like

Share the output of these commands:
java -version and
javac -version