Openhmis cashier error

Application Name: OpenMRS Version Number: 2.0.6 Build 453af9

Every time i try to save and post a bill i get the following error the account has provider privillages and all required jasper reports has been added

cc @BandaHealth

Hello @omrsegypt,

The Cashier module does not yet work well on OpenMRS Platform version 2.x We are in the process of updating our modules to run on OpenMRS Platform version 2.x At the moment Consider using Platform 1.11.x with reference application version less than 2.5


@whiscard Can you please provide me with download link to platform 1.11.X and reference application 2.4


ok installed openmrs 1.11.7 Build 683779 and reference application 2.4

i get these two errors

reporting modules 0.10.0 give me

Unable to update data model using liquibase.xml. Module: Reporting

provider mangement 2.4 gives me

Error while trying to start module Error while running sql: CREATE TABLE providermanagement_provider_role ( provider_role_id int(11) NOT NULL auto_increment, name varchar(255) NOT NULL, description varchar(1000), creator int(11) NOT NULL default ‘0’, date_created datetime NOT NULL default ‘0000-00-00 00:00:00’, changed_by int(11) default NULL, date_changed datetime default NULL, retired tinyint(1) NOT NULL default ‘0’, retired_by int(11) default NULL, date_retired datetime default NULL, retire_reason varchar(255) default NULL, uuid char(38) NOT NULL, PRIMARY KEY (provider_role_id) ) ENGINE=InnoDB DEFAULT CHARSET=utf8 . Message: Table ‘providermanagement_provider_role’ already exists

i run java 8 mysql 5.6 tomcat 7

@omrsegypt you need to use Java 7 instead of Java 8.

Are you still running into this issue?


sir i tried to install it with java 7 . openjdk 7 mysql 5.6 tomcat7 manager alone because on ubuntu it installs on openjdk 8

i ran to the first error again . it is frustrating and i am genuinely considering to not using openmrs at all

can you please provide all data and modules and server status data that you installed on openhmis site

@insiderish @whiscard

@omrsegypt I’m sorry for all the troubles you are experiencing.

Which version of openhmis.cashier, openhmis.inventory, openhmis.commons are you using?

Also, try to use the oracle java 7 (replace it with openjdk).

If this still doesn’t work, kindly send your full logs and we’ll try to identify where the issue is.



Looks like its not a java version issue, its a mysql version issues, mysql version should be <=5.6