openERP - Secure Connection Failed

Hello again. I am trying to install bahmni on virtual box with vagrant, just to familiarise myself with the installation process.

openMRS and openELIS are working fine, however, when I try to open openERP through port 8069. I obtain a ‘Secure Connection Failed’ error.

Details: SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long).

-Daniel Ng-

The problem might be because of using https in the url. Try using http.

Tried that, but instead of the SSL error, this time I am getting:

The site could be temporarily unavailable or too busy. Try again in a few moments. If you are unable to load any pages, check your computer’s network connection. If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Tried with chrome as well: Google Chrome could not load the webpage because took too long to respond. The website may be down, or you may be experiencing issues with your Internet connection.

Looks like OpenERP is not running. Can you try starting it? service openerp start and for starting postgres service postgresql-9.2 start

If the services are already running try restarting them.

I have done the following but am still receiving the same error.

Possibly it is an issue with the ssl configurations? Though I do see port 8069 specified there.

Can you check the logs in /var/log/openerp/. Maybe it is not able to startup or something.

On the most recent entry in the log states: INFO openerp openerp: OpenERP server is running, waiting for connections…

Similar connection error when I try connecting.

Can you run fuser 8069/tcp. It gives the process id of the process that is using the port. Check for the process name by ps ax | grep PROCESS_ID.

@aj.jaswanth My output is as follows: [danielng91@bahmni-2 ~]$ fuser 8069/tcp [danielng91@bahmni-2 ~]$ sudo fuser 8069/tcp 8069/tcp: 15532 [danielng91@bahmni-2 ~]$ ps ax | grep 15532 15532 ? Ssl 0:58 /usr/bin/python /usr/bin/openerp-server -c /etc/openerp/openerp-server.conf --update all --database openerp --without-demo all --pidfile=/var/run/openerp/ --logfile=/var/log/opene rp/openerp-server.log 23141 pts/1 S+ 0:00 grep 15532

Sorry for the late reply. Was busy past few days. And thank you so much for your time!

-Daniel Ng-

Looks like, the openerp service is running. It might be because of iptables blocking the request. Try disabling iptables and check

  • service iptables stop *


@sandeepe, just tried stopping iptables, still obtained the same result. Tried accessing after restarting both openerp and postgresql-9.2 but with the same result as well. :confused:

This problem seems to be haunting me no matter where I install bahmni. Virtual box, cloud server, dedicated physical server. The only thing that gets it up and running is Vagrant.

-Daniel Ng-

cc : @vinkesh @rnjn @bharatak

OpenERP is not accessible at 8069. OpenMRS and ELIS are working fine.

Can you please check the logs for openerp after restart : /var/log/openerp/openerp-server.log

Does it show any error ?

Hello @vinkesh.

I tried restarting postgresql-9.2 first before restarting openerp. I see two errors: 2016-03-15 09:23:53,900 30028 ERROR openerp assertion "For all Journal Items, the state is valid implies that the sum of credits equals the sum of debits" failed! 2016-03-15 09:24:15,768 30028 ERROR openerp openerp.modules.loading: At least one test failed when loading the modules.

Full error message just in case you’d like to see? D:

Thank you

-Daniel Ng-

Are you still stuck in getting OpenERP to run on your vagrant box?

So sorry for the late reply! And thank you for the suggestion!

Yes, unfortunately I am still having problems with openERP. Otherwise, other services run fine.

A note as well, it is not on a vagrant box I am trying to set it on. It is on centOS itself.

-Daniel Ng-

Hello Daniel Ng,

@vinkesh will contact you over a private message to share skype details. Can you respond to the private message, and setup a screenshare on skype with @vinkesh.


Thank you @vinkesh for your time in solving this issue.

Ultimately, because bahmni was installed on Google Cloud Platform, port 8069 was being blocked.

Solution: Go to Google Compute Engine --> Networking Go to Firewall Rules Create a Firewall Rule for port 8069.

Thank you!