OpenERP/Odoo unable to sync data in Bahmni from second entry onwards

Tags: #<Tag:0x00007f23e757e290> #<Tag:0x00007f23e757e100> #<Tag:0x00007f23e757dfe8> #<Tag:0x00007f23e757ddb8>

I tried creating patient in Bahmni EMR . On first time of patient creation it successfully got synched to Odoo and a corresponding customer entry was created. However from second time of patient creation its not getting synched to odoo.

The reason I found out that in the Odoo postgres DB in its markers table the value of feed_uri_for_last_read_entry column against the “patient” entry is getting changed to http://http/openmrs/ws/atomfeed/patient/1 which seems to be invalid URI. On changing this value to ‘http://localhost:8050/openmrs/ws/atomfeed/patient/1’ manually, the entries are getting synched within 2-5 seconds successfully.

Please help me in fixing this error

@user007 (padmesh) Are you tried to delete the markers table records …? If no then do that and restart the Odoo service

And also post the log of Odoo This can help to find out the issue.

@gsluthra @sushantpatil1214 I have tried removing markers table records and restarting. The new event is also being created successfully but the problem is that the polling url in the markers of table Odoo under the feed_uri_for_last_read_entry column is getting modified to http://http/openmrs/ws/atomfeed/patient/1 which u can see is an invalid url. This is happening as soon as a new patient is created on Bahmni EMR.

So due to this the polling can’t happen and the syncing gets paused.However on changing url manually to its valid form i.e. http://localhost:8050/openmrs/ws/atomfeed/patient/1 syncing happens within 2-3 seconds correctly.

But this is not the intended behaviour. Please help me finding why the url is modified in such form on new patient,encounter,lab,drug creation.

Can someone help me on this? @angshuonline @suruchi @gsluthra @sushantpatil1214

Can you check the settings in /opt/bahmni-erp-connect/WEB-INF/classes/erp-atomfeed.properties? Are the host names and URLs correct there?

Also check: /opt/bahmni-erp-connect/etc/bahmni-erp-connect.conf