OpenERP not installing

Hello everyone, I am installing bahmni v0.88 on centos6.8 on linode. but openerp will not install plus i cannot access it on my browser, I on get the maintanance page. here are some screenshots @sravanthi17

Can you manually try installing bahmni-erp

yum clean all yum install -y bahmni-erp

Hi Sravanthi,

We tried with yum install -y bahmni-erp.

But we are getting error.

This looks like an issue. Temporary solution that helped me fix in my local machine

yum install -y

yum install -y bahmni-erp


Thank you sravanthi,

It is worked.

thanks, this fixed the installation problem, but I cannot views it on my browser even after starting openerp and it says running. but on the browser the page does not load

MX is, according to , “(…) a currently experiemental toolkit for the meego-netbook implementation.” So maybe MX could be dropped from the dependencies of the bahmni-erp-0.89-43.noarch package. But I cannot dig deeper into this as I cannot find the RPM build process on GitHub.

It would be nice if you resolve this issue for the next community release as due to this issue Bahmni cannot be installed neither on a CentOS 6.8 VM nor on Digital Ocean with CentOS 6.9 with the documented installation instructions.

@ramashish, This is the same problem which I faced when I tried to install Bahmni for our hospital. As this problem has already been reported here I don’t need to open a new thread. Here are more details about what I tried out:

Hi @janux,

Did you try above command to install MX dependency for openERP. You can include this command after the yum install bahmni-installer command in your script. This will fix the issue for now and We will give fix in the next release.

Please check this below Bahmni-package repo for bahmni-erp RPM files.

Hi @janux, We have created a mingle card to fix the issue. You can track it here #3592

1 Like

Hello @binduak,

Thank you for creating a ticket for this issue and giving it a high priority.

Yes, I tried the command above and it worked out.

hi @sravanthi17

while installing bahmni installer still getting same error, after installation place to error then bahmni-erp needs to install ? or before starting bahmni installer needs to install bahmni-erp ? could you plz clarify, thank you.

With best regard. Tej bhandari

hi @dpresence

have you fixed your error bahmni-erp ? here i have the same issue, if you have already fixed please let me know the way how you walk. thank you!!

with best regard tej bhandari

I also have this problem while installing Bahmni 0.89 on CentOS 6.9 *64 (on Digital Ocean Cloud)

no, not yet

Did you find solution for this issue?

hi i have install well or after i check service i have this error

[root@hopital bahmni-lab]# service --status-all abrt-ccpp hook is installed abrtd (pid 2702) en cours d’exécution… abrt-dump-oops est arrêté acpid (pid 1837) en cours d’exécution… atd (pid 2756) en cours d’exécution… atomfeed-console is running with pid: 2083 auditd (pid 1585) en cours d’exécution… automount (pid 1921) en cours d’exécution… Service bahmni-erp-connect is not running Service bahmni-lab is running with pid: 8591 Service bahmni-reports is running with pid: 2101 Syntaxe : /etc/init.d/bluetooth {start|stop} certmonger (pid 2807) en cours d’exécution… Stopped cgred est arrêté Frequency scaling enabled using ondemand governor crond (pid 2739) en cours d’exécution… cupsd (pid 1804) en cours d’exécution… DCM4CHEE is not running dnsmasq est arrêté firstboot is not scheduled to run hald (pid 1849) en cours d’exécution… htcacheclean est arrêté httpd (pid 2715) en cours d’exécution… Table : filter Chain INPUT (policy ACCEPT) num target prot opt source destination
1 ACCEPT all ::/0 ::/0 state RELATED,ESTABLISHED 2 ACCEPT icmpv6 ::/0 ::/0
3 ACCEPT all ::/0 ::/0
4 ACCEPT udp ::/0 fe80::/64 state NEW udp dpt:546 5 ACCEPT tcp ::/0 ::/0 state NEW tcp dpt:22 6 REJECT all ::/0 ::/0 reject-with icmp6-adm-prohibited

Chain FORWARD (policy ACCEPT) num target prot opt source destination
1 REJECT all ::/0 ::/0 reject-with icmp6-adm-prohibited

Chain OUTPUT (policy ACCEPT) num target prot opt source destination

Table : filter Chain INPUT (policy DROP) num target prot opt source destination
1 ACCEPT tcp – tcp dpt:5432 /* POSTGRES / 2 ACCEPT tcp – tcp dpt:8051 / BAHMNIREPORTS / 3 ACCEPT tcp – tcp dpt:8050 / OPENMRS / 4 ACCEPT tcp – tcp dpt:443 / https / 5 ACCEPT tcp – tcp dpt:80 / WEB SERVER / 6 ACCEPT tcp – tcp dpt:3306 / MYSQL / 7 ACCEPT all – state RELATED,ESTABLISHED 8 ACCEPT icmp –
9 ACCEPT all –
10 ACCEPT tcp – state NEW tcp dpt:22 11 REJECT all – reject-with icmp-host-prohibited 12 ACCEPT all – /
lo / 13 ACCEPT tcp – tcp dpt:22 / SSH */

Chain FORWARD (policy DROP) num target prot opt source destination
1 REJECT all – reject-with icmp-host-prohibited

Chain OUTPUT (policy ACCEPT) num target prot opt source destination

irqbalance (pid 1688) en cours d’exécution… Checking jexec statusKdump is operational lvmetad est arrêté dmeventd est arrêté mdmonitor est arrêté messagebus (pid 1726) en cours d’exécution… mysqld (pid 2419) en cours d’exécution… le module netconsole n’a pas été chargé Périphériques configurés : lo eth0 Périphériques actuellement actifs : lo eth0 NetworkManager (pid 1741) en cours d’exécution… rpc.svcgssd est arrêté rpc.mountd est arrêté nfsd est arrêté rpc.rquotad est arrêté rpc.statd (pid 1764) en cours d’exécution… grep: /proc/fs/nfsd/portlist: Aucun fichier ou dossier de ce type ntpd (pid 2067) en cours d’exécution… oddjobd est arrêté openerp-server est en cours d’exécution… Service openmrs is running with pid: 2502 Service pacs-integration is not running portreserve est arrêté master (pid 2673) en cours d’exécution… postgresql-9.2 (pid 2551) en cours d’exécution… pppoe-server est arrêté La gestion des processus est désactivée. quota_nld est arrêté rdisc est arrêté Low level hardware support loaded: none found

Upper layer protocol modules: none found

User space access modules: none found

Connection management modules: none found

restorecond (pid 3478) en cours d’exécution… rngd est arrêté rpcbind (pid 1706) en cours d’exécution… rpc.gssd est arrêté rpc.idmapd est arrêté rpc.svcgssd est arrêté rsyslogd (pid 1619) en cours d’exécution… sandbox is stopped saslauthd est arrêté smartd est arrêté spice-vdagentd est arrêté openssh-daemon (pid 6047) en cours d’exécution… sssd est arrêté wdaemon est arrêté winbindd est arrêté wpa_supplicant (pid 1805) en cours d’exécution… ypbind est arrêté

[root@hopital bahmni-lab]# service bahmni-erp-connect start Starting bahmni-erp-connect [root@hopital bahmni-lab]# nohup: appending output to /home/bahmni/nohup.out'** **nohup: failed to run command/usr/java/jre1.8.0_101/bin/java’: No such file or directory

Same problem here:

[root@dhcppc10 html]# sudo service bahmni-erp-connect start Starting bahmni-erp-connect nohup: appending output to /home/bahmni/nohup.out' nohup: failed to run command/usr/java/jre1.8.0_101/bin/java’: No such file or directory [root@dhcppc10 html]#

How to solve this? Anyone?


go to


[root@user html]# sudo nano bahmni-erp-coonect.conf

-change JAVA_HOME=/usr/java/jre1.8.0_101 to JAVA_HOME=/usr/java/jre1.8.0_131

-start bahmni-erp-connect service again

this worked for me.