OpenERP modules are not showing up

Hello,

Application Name: Bahmni Version Number: 0.90 Question: I just installed Bahmni Vagrant Box version 0.90

I am trying to access all the application and do needed setup to execute my workflow.

When i logged into openERP there are no modules visible. I tried to create database from the login page. however no application modules are showing up and also i dont see any application modules installed in application.

On the demo machine hosted by Bahmni - i see the modules bar , except customers - other features are not showing up.

Should we setup something manually in order to have openerp application as seen in the bahmni videos?

OpenERP server status is running.

Regards Jayasri

1 Like

Hello,

I tried to install the modules manually from list of uninstalled modules from openerp.

Was able to install accounting module, sales module fully. I get error while installing purchase and warehouse management - Openerp server error. Then it appeared it installed, Purchase and Warehouse shows on the module tab in Openerp. however if I click on Purchases it’s pointing to Customers. Same for Warehouse. I tried to uninstall, similar error shows up for install, uninstall of any additional modules including Bahmni modules.

Request for help. Its urgent as I am arriving at workflow for one of the implementations

Hi @jayasri,

I don’t see any issue with openERP on Vagrant Box 0.90v. I will recheck and confirm. Meanwhile you can try restoring the openerp database to make it work. You can get the openerp database from here. Let us know if you need any help.

Thank you Himabindu for your response.

If you see no issue in vagrant box, I should also not see the issue. Because the very nature of vagrant box is such and that’s the advantage of having a vagrant box. But I am seeing the issue and also noticed the same issue on demo.mybahmni site too.

If I restore the erp database it may not work, the reason is application installation did not happen for Purchase and Warehouse modules due to error I stated in my earlier response.

It will be great, if vagrant box works as expected.

I downloaded the vagrant box and made it up. Please let me know if you have done any other steps post the downloaded of vagrant box and making it up.

@jayasri I don’t see any issue on demo with openERP and with vagrant box too. Can you please share a screenshot of the issue, so that we can help you solve the issue.

you can give a try.

No extra steps needed post vagrant box setup to use openerp. You just have to start both openerp and bahmni-erp-connect services.

Hello Himabindu,

I have taken the screenshots from https://erp-demo.mybahmni.org/, I am attaching them to this thread.

ERP - Sales Tab -> shows only customers.

ERP - Warehouse Tab-> shows customers again, I guess which ever page you see that gets reflected when we click on other modules.

ERP-Settings, shows its features

Similar way I see in my system too. I tried to uninstall the modules and install it again, I see the issues pasted in my earlier message.

@jayasri

I just figured it out in demo that OpenERP app is using wrong database. Please make sure the database being used by OpenERP should be openerp that comes with installation. You can check it from openerp logs.

/var/log/openerp/openerp.log

is the log file.

Can you please get this updated in vagrant Box too. I will download it again and bring it up.

@jayasri I will do that if there is really a issue with Vagrant box. I have checked it yesterday by downloading the new box. I don’t see this issue. Can you recheck from your end by downloading the new 0.90v vagrant box.

Himabindu,

Thank you for your response.

I have been to customer place yesterday. Two days back vagrant box was setup in their machines. So yesterday, I opened the openerp application to verify, There are no modules except settings and its features. In Installed, there are no application modules installed except basic modules.

Are we missing any setups post setting up of vagrant box.

@jayasri I also downloaded the latest vagrant box and did not face any issue in setting up and using openERP. I did not have to do any extra steps except start 2 services with these commands

  • service openerp start
  • service bahmni-erp-connect start

Have you checked if the database you are using the right one as pointed out by @binduak? Please let us know if you need any help in doing this.

1 Like

Thanks Sruti. I will make a customer visit again on Wednesday, I will check the database it’s pointing to and let you know.

Let me try in my machine again by pulling the vagrant Box.

Will get back. We were actually planning to manually install the application thru bahmni installer than using vagrant because openerp wasn’t working…before that we will try once again…

Sruti,

I have downloaded the vagrant box again and set it up. This time around also ERP did not show up any modules. What I have done was, downloaded openerp database that Himabindu pointed out , unzipped it and restored it. Then the modules showed up.

I guess this should have gone as part of Vagrant box right?

BTW , I am not seeing separate module for inventory. I think had seen in odoo erp. Is this fine?

Modules showing up are: Messaging, Sales, Accounting Purchases Warehouse Human Resources Reporting Settings Is this correct?