Open Elis login error (on Docker)

I can login successfully to Open Elis but when i click on collect sample i get logged out with an error that reads "Your session has expired, Please login again.

Hi @tamunoseimiebi My team works a lot on OpenELIS, so we’re happy to help. Can you tell me which version of OpenELIS you are using? Is it part of Bahmni, or just OpenELIS on its own that you are using?

Hi @janflowers I am using the version that comes with Bahmni

Ah ok. My team doesn’t work with Bahmni at this time. The Bahmni version of OpenELIS was forked long ago and isn’t aligned with the core OpenELIS codebase, so I can’t help you on the problem you are experiencing, as the OpenELIS community at large doesn’t support that version anymore. If you are just looking to use OpenELIS as a standalone, we can point you to the current codebase, built in Spring for the app itself and incorporating the HAPI FHIR JPA server for exchanges. Otherwise, @angshuonline is there someone in the Bahmni team that can help @tamunoseimiebi?

1 Like

Hi @tamunoseimiebi . I would like to help you on this issue. Are you using the default user credentials for OpenELIS ? Also can you please help me with the version of Bahmni that you are using ?

Hello @mohant Thanks for offering to help. I am currently not sure of the version I am using but it was setup using docker, i will attach some images to this and yes, i am cusing the default OpenElis login detailsScreenshot from 2021-11-07 12-57-22

Thanks for sharing the details. Let me investigate and get back to you. In the mean time, can you please let me know what are the steps you have followed to “Collect Sample” ? Are you making a Lab order from Bahmni EMR and then clicking Collect Sample from Lab Dashboard ?

So basically, i registered a patient via the bahmni app and requested for lab tests. I logged in to OpenElis to enter the lab results but whenever i click on collect sample or any other menu on the openElis dashboard i get logged out with the session expired error

@tamunoseimiebi Thanks for the sharing the flow. However this issue seems to be weird, because I couldn’t reproduce it in my local. I have tried entering lab results for new patients and also for existing patients. I have tried it in Chrome. What happens when you login again after session expired error and try to enter the results ? Also what browser are you using ?

after logging in again the process repeats, i have tried firefox and chrome browsers. Can we have a brief call on microsoft teams so i share my screen?

Yeah sure! Let’s connect.

This is the error gotten from the server logs.

Thanks for sharing this @tamunoseimiebi . Also please try docker-compose restart from the bahmni-docker directory if that helps?

Alrght, i will give that a try

Hi @mohant I have just setup bahmni on a new instance with more resources but i am still getting the same error