On Docker, Unable to login to mysql for openMRS DB


I have setup on Docker but unable to login. Any pointers on whats the cause and solution that i need to follow?

Best Regards.

Hi @supriyat,

To better understand the issue you’re facing with logging into your Docker setup, could you please provide more information about your setup? For instance, could you tell me how you set it up and which guide you followed? This information will help me provide more targeted guidance on the cause and solution to your login issue.

Looking forward to hearing from you soon.

Hi @jayasanka We used https://bahmni.atlassian.net/wiki/spaces/BAH/pages/299630726/Running+Bahmni+on+Docker and this option ‘Bahmni Standard on Docker’ (https://bahmni.atlassian.net/wiki/spaces/BAH/pages/3117744129/Getting+Started+Quickly+with+Bahmni+on+Docker#Running-Bahmni-Standard)

Thank you.

Best Regards.

This env file contains usernames and passwords for each DB:

I believe you are running bahmni-standard. if so, then see the .env file in bahmni-standard sub-folder for OpenMRS DB credentials.

Also see point 1. of this document (connecting to openmrs db): https://bahmni.atlassian.net/wiki/spaces/BAH/pages/49545219/Connecting+to+various+databases

You will need to ssh into the openmrs db docker container, and then fire the command as mentioned in point 1 of the above wiki document".

Sorry for the delay in replying back. Well, before trying above steps docker should be in the running state which is not happening in our case. Stuck in it and not able to start the docker itself… we will get back to you.

Thank you.

Best regards.

Hi @supriyat ,

Use these commands:

docker ps //to check whether docker containers are up

docker logs -f openmrs-container-id //to check what is the error log you are getting. Please share the error logs.

So when I try to start the docksal-dns and docksal-vhost-proxy containers, I get the error as per the attached screenshot. Not sure how to try to resolve this.

Have tried many options that I came across from google search and none worked for me. Any insights on how can I resolve this issue?

@mohant @umairfayaz Can you help here?

@supriyat The issue seems related to docker engine not starting properly. What is the container engine are you using Docker Desktop or Colima ?

Hi Mohant,

This is docker on Ubantu server. I’m guessing it would be docker desktop?? Is there a way to check this?


You can check that by running docker info. By the way why do you want to start those specific containers ?

yes. we want to start these containers but not able to due to the error in the screenshot. Thanks.

FYI, currently containers are in the stopped state so want to start them.