O3 Docker No Longer Working

Hi all, I used the Docker Compose file recommended from docker-compose.yml for running an instance of Openmrs3. It used to at least launch and show pages like dashboard and log-in, but no longer works. The nightly tag give errors on the openmrs3-docker-backend saying “No permission to remove … omod files”. I tried the latest tag, but when I access the endpoint (i.e. /openmrs, etc), I just see the request as cancelled/failed showing “Err_Connection_Refused”.

Anyone able to run the openmrs3 with docker? Thanks

When was the last time you used O3 and it worked? If your volumes pre-date changes to O3 docker revamp (~4 months ago), please try running “docker-compose down -v” to remove old volumes and “docker-compose up” to start the setup from scratch.

If it doesn’t fix the issue, could you please paste the full log?

1 Like

Hi Rafal, thanks for your response. I re-ran it after ‘docker-compose down -v’ and it passed the initial stage. Now it gets stuck on the initial-setup at the “Update the database” stage. Here are the logs: o3-initial-setup-error.log · GitHub

1 Like

Have you tried manually refreshing on the initial setup page?

Have you linked the correct logs? From the one you linked it seems that the server started up and responded correctly to lots of requests.


Yes, those are the correct logs. Unfortunately, the browser console logs show errors when even after I refresh the page.

@zotis please share the browser console logs.

1 Like

Hi @raff - find below the screenshot.

This time, I cloned the whole repo: GitHub - openmrs/openmrs-distro-referenceapplication and ensure that my docker was empty (no containers running or images). Then proceed with docker build and up.

When I refresh the page, I see some other browser console logs saying “Uncaught Error: Failed to fetch new session information: undefined”

I just retried again, and it worked! I didn’t change anything. Thanks for your help!