No User Module Installed Error


(Madhav Kauntia) #1

I forked the openmrs-core repository, cloned it onto my computer, then built it using mvn clean install. When I run it on the Jetty or Tomcat server, and finish installation, I get an error which can be seen in the picture. I followed the instructions in https://wiki.openmrs.org/display/docs/User+Interface+Modules and installed the Legacy UI module by cloning https://github.com/openmrs/openmrs-module-legacyui.git and then building it and copying the .omod file to %appdata%/OpenMRS/modules. Then I restarted the server and I’m still getting the same page. How should I proceed?


RefApp 2.8.0 Installation Issues
(Aditya Bisht) #2

If you want to install OpenMRS in your PC then I believe this link will be helpful to you :smiley:


RefApp 2.8.0 Installation Issues
(tendo kiiza Martyn) #3

madhavkauntia platform is telling you it’s missing some basic modules are missing . this problem was handled at OpenMRS Platform installation - No User Interface message


(Gibril Gómez) #4

Kindly go through this link and try this approach

https://wiki.openmrs.org/plugins/servlet/mobile?contentId=589853#content/view/589853

Regards

Gibril


(Madhav Kauntia) #5

I tried the approach given in the above link, but I keep landing on the same page. I’m deploying the .war file in the openmrs-core/webapp/target folder. I finished the installation successfully and I’ve got sample data added to my MySQL database, but I’m not able to access OpenMRS from localhost:8080/openmrs. It keeps landing me on this page:


(Gibril Gómez) #6

Try downloading the module package specific to your installation version and extra all, paste all to the module directory. Then restart and try again.

Regards

Gibril


(Nurudeen Lawal) #7

Goto system32 in windows, config, appdata and openmrs the drop your module folder inside. Restart the tomcat. Also try adding adding /login.htm after the openmrs in the browser.