No properties file at all but openmrs intital setup fail using some properties !!!!

Tags: #<Tag:0x00007fdb780145e0>

i have installed openMRS entreprise 2.1 on mySQL 5.5, Tomacat 7. and worked well. 2 days after mySQL start bugging and i use it for 2 other apps. i have unstalled it and installed 5.7. Since that day, openMRS refuse to start !!! i have uninstalled tomcat and reinstalled it and deploy openMRS many times but still getting:

“Error occurred while trying to get the updates needed for the database. Unable to get a connection to the database. Please check your openmrs runtime properties file and make sure you have the correct connection.username and connection.password set” I have deleted all files and directories related to openMRS in my server ( win 10) => no trace ever of openMRS. I have reinstalled tomcat 9 and mysql 5.7 and deployed openmrs: when i start it hoping getting the intialsetup and the wizzard, it display the same error !!! that he cannot conect to db, using some credentials i dont knom from where he pull them !!! As no trace of properties file in my server !!! even after deploying i cant find anything about openMRS properties file in my server !!!

Any help please as i got only 2 days to deploy it !!!

Hi @ltf,

The error suggests that it has trouble connecting to database. Few of the troubleshooting steps to check the exact problem:

  • Please try connecting to the database with credentials
  • Please ensure that MySQL server is up and running before starting OpenMRS
  • Which OS are you using… Windows, Linux?

Have you tried to run a search for “*.properties” files on all drives?

I have deleted all files and directories related to openmrs from my entire server, all drives!!! One new thing today: While my server is totally clean from openmrs, I have downloaded the stand alone version: Got the same error in the browser :pensive::sob::sob::sob::sob::sob::sob: I think my server is haunted !!!

Interestingly, the standalone version has a built-in database, so you shouldn’t have this error. Have you tried to run this version on a different machine? Physical or virtual.

It would be helpful to share the full log instead of just bits of it. Of course via a paste site like pastebin.com. :slight_smile:

1 Like

@ltf When @dkayiwa was asking for a full log, it would be helpful to provide the full log instead of just a long view of the error. This is because there are other messages in the log that would tell us exactly where it’s loading the properties from. Nonetheless, the “ghost” properties file is probably in %USERPROFILE%\Application Data\OpenMRS, which, on Windows 10, would be something like C:\Users\<username>\Application Data\OpenMRS`.

hi ibacher: the Config is: Java SDK (build 1.8.0_261-b12), Win 10 64bits pdate 2004, Apache tomcat 7. Mates, i have foud the ghost !!! :slight_smile: it is here: C:\WINDOWS\ServiceProfiles\LocalService\Application Data\OpenMRS\openmrs-runtime.properties

thank you all :slight_smile:

1 Like