no any patient and order are synced from mrs to erp in bahmni-0.92/odoo-10

Tags: #<Tag:0x00007f077418dbe8> #<Tag:0x00007f077418d788>

Hi , I am facing problem in bahmni-0.92. after restoring backup from yesterday auto schedule backup no any patient and order is synced from mrs to erp.

atomfeed shows me this error

Failed processing event in feed [http://localhost:8050/openmrs/ws/atomfeed/encounter/1] java.lang.RuntimeException: warning – Patient Id not found in openerp java.lang.RuntimeException: java.lang.RuntimeException: warning – Patient Id not found in openerp at org.bahmni.feed.openerp.worker.OpenERPSaleOrderEventWorker.process( at org.ict4h.atomfeed.client.service.AtomFeedClient$EventProcessor.doInTransaction( at org.ict4h.atomfeed.transaction.AFTransactionWorkWithoutResult.execute( at org.ict4h.atomfeed.server.transaction.AtomFeedSpringTransactionSupport$1.doInTransaction( at at org.ict4h.atomfeed.server.transaction.AtomFeedSpringTransactionSupport.executeWithTransaction( at org.ict4h.atomfeed.client.service.AtomFeedClient.processEvents( at org.bahmni.feed.openerp.job.SimpleFeedJob.processFeed( at org.bahmni.feed.openerp.job.OpenERPSaleOrderFeedJob.processFeed( at sun.reflect.GeneratedMethodAccessor68.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) at java.lang.reflect.Method.invoke(Unknown Source) at org.springframework.util.MethodInvoker.invoke( at org.springframework.scheduling.quartz.MethodInvokingJobDetailFactoryBean$MethodInvokingJob.executeInternal( at org.springframework.scheduling.quartz.QuartzJobBean.execute( at at org.quartz.simpl.SimpleThreadPool$ Caused by: java.lang.RuntimeException: warning – Patient Id not found in openerp at org.bahmni.openerp.web.client.OpenERPResponseErrorValidator.checkForError( at org.bahmni.openerp.web.client.OpenERPClient.execute( at org.bahmni.feed.openerp.worker.OpenERPSaleOrderEventWorker.process( … 16 more

Moved to the bahmni category.

Have you tried on later versions of Bahmni 0.92?
Also, I would advise don’t use the default config (which uses default database dumps rather than creating from base) till we sort it out. You can try configuring Odoo from base setup and it will work. You will need to follow the instructions here

The Release Candidate should be out very soon. If you can’t wait (and you must start from default setup), ping us on Slack.

Hi, i updated 0.92-99 and installation was fine. when i tried to access clinical services the whole module is meshed up . what might be the issues. i have attached the screenshot