Naming convention unit test

Am I correct in assuming that the current naming convention is (as in the OpenMRS template for Eclipse)

	public void shouldSentence() {...

Or is the picture in correct which says

       methodName_shouldSentence() ?

How about adding tests to test classes using an older version of the naming convention. Keep the pattern or stick to the rule?

What would your advice be? :smile:

I quite like


since it let’s one easily see which method is being tested.

I like it too. :slight_smile:

@dkayiwa wouldnt that idea demoralise the aspect of object oriented programming. inotherwords assuming you need to add another previleges in that object , how would you add them inorder to encapsulate the whole method, thanks