Metadata Sharing Does NOT work

Hello all, I tried to export htmlform using metadata Sharing Module 2.2.1 and Openmrs 2.0.5 . I ran into the following error:

I was able to duplicate the error on the demo server. However, I cant provide link as the process is not completed and therefore not saved.

Any help is much appreciated

This line of StandardRegimenTagHandlerSupport1_10 references the class RegimenSuggestion:

attributeDescriptors.add(new AttributeDescriptor("regimenCodes", RegimenSuggestion.class));

And RegimenSuggestion was removed from Core 2.x (commit here, see TRUNK-14).

@dkayiwa, looks like that a StandardRegimenTagHandlerSupport2_0 should be introduced that stops doing that?

@yadamz, the actual error was:

java.lang.NoClassDefFoundError: org/openmrs/order/RegimenSuggestion
    at org.openmrs.module.htmlformentry.handler.StandardRegimenTagHandlerSupport1_10.createAttributeDescriptors( 

As in: no class definition found for RegimenSuggestion, leading me to check that it indeed was nowhere to be found on Core master (or any 2.x branch). However I saw that it still existed on Core 1.12.x (see here).

@mksd that is a very exhaustive description of the problem and fix. :slight_smile: Do you wanna create a ticket for it? And possibly attach a pull request if you have the time?

Here: RA-1388: ‘New StandardRegimenTagHandlerSupport2_0 should not refer to RegimenSuggestion anymore’

I will not be in a position to work on this at all though I’m afraid. @yadamz, could you?

Thanks @dkayiwa and @mksd for the great feedback.

I have created a ticket for the issue here is the ticket

Unfortunately @mksd I am not a developer but a provider/implementer.

@yadamz this is the ticket with which it will be fixed

@yadamz can you test the module attached on the above ticket and tell us if it fixes the reported problem?