medication treatment not sync with openerp

i wrote a prescription on my default bahmni virtualbox and it went successfully. but the issue is the prescription is not reflecting at openerp. lab request reflect at openelis, atom feed is running smoothly but openerp doesnt pick it below is a snapshot

Hi Tom, Can you see if this helps. And atomfeed-console is not the ERP sync, its bahmni-erp-connect. Please go through the wiki links provided to understand the difference. Here is documentation about the services of Bahmni.

All services are fully enabled. The point is that ERP can’t record prescription buy or kab order from end. Any solution to solving tgis core issue would go a long way

Can you verify if bahmni-erp-connect service is running

halted vagrant. vagrant up. and started all services solved it!Please how can i set all the core services to auto start so Cent OS load it loads all services.Thanks alot Follow the steps mentioned in the documentation.

done it Thanks. Sorry for going off topic. my implementer interface redirects to an empty page. i cant seem to find a form builder app like in the videos. am i missing something

please check if the rpm bahmni-implementer-interface is installed. You can use the below command yum list installed | grep bahmni-implementer-interface

When i ran the command , it gave me this below

It is clear that implementer-interface is not installed and thus you were not able to just see an empty page. If you want to install implementer-interface, then add the following line in /etc/bahmni-installer/setup.yml > implementer_interface: enabled

Rerun the bahmni install command

The biggest challenge have is inn ability to modify setup.yml file. I am using winscp to access it. When save changes to it , it tells me permission denied. I even changed the permission using chmod 0777 setup.yml. still permission denied. Thanks

Maybe you can attach a screenshot of the error message, and a screenshot of the permissions on the file (using the “ls -al” command).

Or learn how to edit a file using “Vi” command in putty. Here is a video: You can directly edit the file via putty.

yeah i know i thought i could use sublime in windows.i can open it using winscp . i can access all folders and even edit code files, but when i save it , it throws permission error

You have to switch to root user. Right now you are using vagrant user for whome there are no permissions to edit the file.

It didn’t work. Here is what did. I accessed the box via putty. Typed su and put vagrant as root password. It switched to root. Opened winscp and accessed my folder directory in winscp GUI. It like filezilla . But when i try opening it, it still doesn’t permit editing. . Thanks