Making my first Module

Hey guys I am making my first module. At first everything was going on well but then then this error started coming up now i cant seem to access openmrs locally on my machine @jwnasambu @odorajonathan @herbert24 @dkayiwa

@suubi7 Is the error appearing on an SDK or standalone instance?

This one in the image is occuring in the standalone instance but the SDK one is longer

“500- Internal Server Error” message, means something has gone wrong with the website. This isn’t a problem with your browser, your computer, or your internet connection. It’s a problem with the site you’re trying to visit but the server could not be more specific on what the exact problem is. Are you trying to access the module you created on standalone? if yes that is the course of the error. You can only see the module on your SDK instance. If not, kindly refresh the page and share the output. Kind request please! always use pastebin to share entire errors for easy identification of the problem.

On standalone the error disappears when i refresh but on the SDK even if I refresh the page the page does not return to the sdk

But i have created another port and server and now am rerunning the sdk it seems to be working ( I can access the edit module add button) Like this

the output after refreshing About Pastebin will do that thank you

Just wondering how long should this process take?

Kindly share the output once its done.

Guys this has been going on for hours is this okay almost half a day. Is this okay?

I was able to fix this thanks guys. STEPS I USED

  1. Make sure you have a strong internet connection
  2. Rerun the OpenMrs sdk.
  3. And follow the procedures at Making Your First Module · GitBook
1 Like