Liquibase Cannot create Tables

The real reason is Liquibase cannot write the tables on the Database is unknown so that’s why i needed the error log.

hbm.xml and Liquibase changelog

cc. @dkayiwa

Please share the server side error log.

On a side note, is there a reason you are not using JPA annotations instead of xml mapping files? Or is it simply a matter of preference?

1 Like

@dkayiwa that was what i was failing to track ,that’s actually impeded progress.

@willa I previously used hibernate Annotations but liquibase was still throwing same error ,on the contrary i prefer annotations,old school is good but costly.

You may checkout the repo at

I think liquibase problems are independent of hibernate configurations. Try to run the module again, then capture the server side log usually this is catalina.out. The contents the logs will help figuring out what is causing problems.

1 Like

Can you please share the error logs when you attempt to start OpenMRS with the module?

1 Like

@wyclif That is exactly what i was looking for ,the error log for the SDK.could not locate it …Tried searching all hidden folders using “ls -a” but vainly.

thanks @willa but hey am inside the SDK folder where i think tomcat resides.I have not come across catalin.out.Could it be that during exposion ,Ubuntu placed it somewhere else…am using Ubuntu 14 LTS…I have traversed this path but in vain


Do you have any other full path…That would save me a chunk of time.

The logs are in USER_DIR/.OpenMRS/openmrs.log file or CATALINA_HOME/logs/catalina.out

@wyclif thanks alot