Legacy module fails to install

@dkayiwa @reagan @jwnasambu @herbert24
could anyone help me and clearly tell me which file i have to copy from the openmrs-module-legacyui to my modules in the server … i have tried to troubleshoot this severaly but nothing really seems to workout or if anyone has the link that can guid me on this through on windows… i will be glad

Hi @ndacyayisenga,

  1. Download the module from here : https://addons.openmrs.org/show/org.openmrs.module.legacy-ui-module
  2. Copy the downloaded .omod file to your modules directory. (Windows + R > %appdata%>OpenMRS>Modules)

You can find a full guideline here: https://wiki.openmrs.org/display/docs/User+Interface+Modules

1 Like

Another thing that you can do is:

  1. Download the git repo from https://github.com/openmrs/openmrs-module-legacyui

  2. Run mvn clean install.

3.Copy the .omod generated in omod/target folder to your OpenMRS/modules folder.

1 Like

@aman @jayasanka i have tried to follow the steps… and i had done that before but nothing really seems to work out… could there be any other possile hinderance??? cc @dkayiwa @herbert24 @reagan @samuel34 @jwnasambu @jnsereko

Sorry about this! could there be a reason of failing to install the Reference Application? Kindly try this link https://sourceforge.net/projects/openmrs/files/releases/OpenMRS_Reference_Application_2.10.0/. Anyway, did you look at the instructions page on this link https://wiki.openmrs.org/display/docs/User+Interface+Modules Install the module After the download completes, copy the .omod file (legacyui-{versionNumber}.omod) into the modules directory of your OpenMRS app data folder (e.g. ${HOME}./OpenMRS/modules).’ also to keep in mind You should only be installing the legacyui module’s .omod file and not the jar file

@jwnasambu thats exactly what i did

Sorry about it! kindly share the error log.

Hi, I have the same error. Can you share if a solution exists?

could this be of use to you https://wiki.openmrs.org/display/docs/User+Interface+Modules

Thanks, I followed the steps many times and I have the same error.

Could you write here the steps that you followed ?

@omzo what steps did you accomplish on this??

@aman and @herbert24, I resume the project from the beginning. I will keep you informed. Thank you!

1 Like

I fixed the problem. Thank you!