Last minute rudimentary testing for Platform 2.3.2

The pull request needs to update all the pom.xml files.

@dkayiwa Kind help please! openmrs-core 2.3.x CI has build successfully after overriding the development parameter to the next version something I thought would automatically fix the build failure on openmrs platform 2.3.x and the release be reflected on the sourceforge since I had already released platform 2.3.x . On the contrary, standalone build is failing which I suspect the error source is from Liquibase. Kindly how do I go about this to finalize with this release?

cc @ibacher

I have created a pre_platform2.4 branch and configured your CI plan to depend on it. Can you try again?

I have attempt to rerun the build on platform 2.3.x branch, but am getting this error Plan 'OP-OPM7-81' started but a fatal error occurred and this is the entire error log https://pastebin.com/PczmVLKz. To figure out the cause of Unknown RepositoryDefinition 195428353) I followed this steps under "

*Bamboo administration -> Overview -> Build resources -> Linked repositories*

and I didn’t see openmrs platform 2.3.x branch among the Linked repositories yet its the plan am running which makes me suspect is the cause of this error. Though I have seen the add repository option, I wouldn’t like to do it without your consent. Any help is appreciated.

Which branch do you see displayed here? https://ci.openmrs.org/chain/result/viewChainResult.action?planKey=OP-OPM7&buildNumber=82

Its 2.3.x which is building successfully now but the entire of yesterday it was failing to build as reflected on this link https://ci.openmrs.org/chain/result/viewChainResult.action?planKey=OP-OPM7&buildNumber=81 and throwing that error.

I have tried to follow this guide keenly on releasing platform 2.3.x but am stack on step Number 10 and I kindly need help on the way forward. I specified the variable values as maven.release.version 2.3.2 maven.development.version 2.3.3 snapshot and build.release.type releases as its documented in the guide and can be reflected on this link but am running into a compilation error as reflected by the logs on this link https://ci.openmrs.org/browse/OP-OPM7-RTM-82/log of which I have tried to research around on the would be cause of the error and possible solution but its in vain. How can I go about this blocker?

Thanks in advance

@mogoodrich, @dkayiwa , @ibacher

Are you specifying it exactly as such?

No. I just used 2.3.2 because I had an assumption its the version which is need and the snapshot will be reflected automatically. Thanks so much for helping me identify my mistake. To fix it should I rerun the release steps again?

Then what did you mean by 2.3.3 snapshot?

What I meant was " maven.development.version represents the SNAPSHOT version which is 2.3.3. basing on how I understood which was wrong.

Did you specify it exactly as such?

Yes . I used 2.3.3

It is supposed to be 2.3.3-SNAPSHOT

Thanks so much for the clarification! I really appreciate your help.

@dkayiwa After making the changes, I re-run the release stages again but the build on Release to maven did not complete as reflected by this error logs https://pastebin.com/3DR3uStP and I want to think its because the release had already taken place on openmrs-distro-platform/ pom.xml as reflected on the commit history on platform 2.3.x branch on github and by re-running the release stages again the release to maven couldn’t build which may be the cause why this release is not reflected on the file listing page on Sourceforge. Kindly help on how to make the release appear on the sourceforge!

Could not find artifact org.openmrs.web:openmrs-webapp:war:2.3.3.

Are you specifying version 2.3.3 anywhere?

I specified it very well. Its on the core where I had forgotten to specify but I fixed it by raising a pull request.

But we have never released version 2.3.3

I only used 2.3.3 as maven.development.version snapshot but what am releasing is 2.3.2.