jQuery undefined when running Provider Management module


(youssef fathy) #1

[Provider Management] version 2.11

We have been trying to open the module but we have a problem with jquery not running right. It says jQuery is undefined in the providerDashboard.page . I am sure we have the jquery scripts in the uilibrary and we even tried to add a script folder in the resources inside the omod folder with jquery and jquery-ui but no luck. Do you have any ideas on how to fix that?


(tendo kiiza Martyn) #2

@youssef can you please provide all the details of your use case and which browser are you running ?


(youssef fathy) #3

We are working on the ticket PROV-88 , we had a problem running the UI of the provider management module. Cosmin Loan has clarified that the module is using coreapps module instead. for this ticket we have been trying to run the provider management 2.11 on the openmrs sdk server, and when you try to search for a provider it tells you jQuery is not defined. the scripts running are from the uilibrary jQuery scripts which exists but the dashboardpage.gsp couldn’t define jQuery. The problem is solved right now as we will be using the coreapps module instead.