Jest - Unexpected Token in renderer create

Hi Everyone!

Currently I’m trying to integrate the testing framework for ReactJS which is called as Jest. I built my OWA from OpenMRS OWA generator. I developed a component which shows the tabular representation of any given report.

import React from 'react';
import renderer from 'react-test-renderer';
import ReportAsTableView from '../../../components/reports/common/ReportAsTableView';

describe('ReportAsTableView renders correctly ', () => {
    it('renders correctly', () => {
        const params = {
            "startDate": "2017-05-05",
            "endDate": "2017-10-05"

        const rendered = renderer.create(
                <ReportAsTableView reportUUID="e451ae04-4881-11e7-a919-92ebcb67fe33" 
                reportParameters= {params} />

But when I try to run the tests, it fails giving the below error:

 PASS  app\js\sum.test.js
 FAIL  app\js\__tests__\reports\common\ReportAsTableView.test.js
  ● Test suite failed to run

    D:/OpenMRS/OWA/openmrs-owa-built-in-reports/app/js/__tests__/reports/common/ReportAsTableView.test.js: Unexpected token (14:16)
        12 |
        13 |         const rendered = renderer.create(
      > 14 |                 <ReportAsTableView reportUUID="e451ae04-4881-11e7-a919-92ebcb67fe33"
           |                 ^
        15 |                 reportParameters= {params} />
        16 |         );
        17 |         expect(rendered.toJSON()).toMatchSnapShot();

Test Suites: 1 failed, 1 passed, 2 total
Tests:       1 passed, 1 total
Snapshots:   0 total
Time:        0.155s, estimated 1s
Ran all test suites related to changed files.

I assume that this is happening that my component jsx file is not compiled to pure JavaScript. I couldn’t find how to fix this. Any help is much appreciated. @raff

Below is my package.json file

  "name": "openmrs-owa-built-in-reports",
  "version": "0.1.0",
  "description": "built-in reports for reference application",
  "repository": {
    "type": "git",
    "url": ""
  "dependencies": {
    "bootstrap": "^3.3.7",
    "jquery": "^3.2.1",
    "react": "^15.4.1",
    "react-dom": "^15.4.1",
    "react-router-dom": "^4.1.1"
  "devDependencies": {
    "archiver": "^1.0.0",
    "babel-core": "^6.2.1",
    "babel-jest": "^20.0.3",
    "babel-loader": "^6.2.0",
    "babel-preset-es2015": "^6.1.18",
    "babel-preset-react": "^6.16.0",
    "browser-sync": "^2.11.1",
    "browser-sync-webpack-plugin": "^1.0.1",
    "copy-webpack-plugin": "^4.0.1",
    "css-loader": "^0.23.1",
    "extract-text-webpack-plugin": "^1.0.1",
    "file-loader": "^0.8.5",
    "html-loader": "^0.4.3",
    "html-webpack-plugin": "^2.24.1",
    "identity-obj-proxy": "^3.0.0",
    "jest": "^20.0.4",
    "on-build-webpack": "^0.1.0",
    "raw-loader": "^0.5.1",
    "react-test-renderer": "^15.6.1",
    "regenerator-runtime": "^0.10.5",
    "rimraf": "^2.5.2",
    "style-loader": "^0.13.1",
    "url-loader": "^0.5.7",
    "webpack": "^1.12.13",
    "yargs": "^4.3.1"
  "scripts": {
    "clean": "rimraf dist && rimraf coverage*",
    "build": "npm run clean && webpack --progress --colors --mode=production --target=web",
    "build:dev": "npm run clean && webpack --progress --colors --mode=dev --target=web",
    "build:prod": "npm run test && npm run build",
    "build:deploy": "webpack --progress --colors --mode=deploy --target=web",
    "watch": "webpack --progress --colors --watch --mode=deploy --target=web",
    "test": "jest"
  "keywords": [
  "author": "JudeNiroshan",
  "license": "MPL-2.0"

@millicent @kingisaac95 @upendo @jeiddiah am sure you have a response to this. :slight_smile:

1 Like

@judeniroshan Check this out, hope it helps:

@upendo I have added the following element to the package.json. But I still get the same error.

"jest": {
    "automock": false,
    "browser": true,
    "moduleNameMapper": {
      "\\.(jpg|jpeg|png|gif|eot|otf|webp|svg|ttf|woff|woff2|mp4|webm|wav|mp3|m4a|aac|oga)$": "./app/js/__mocks__/fileMock.js",
      "\\.(css|less)$": "identity-obj-proxy"
    "moduleFileExtensions": [
    "moduleDirectories": [
    "transform": {
      "^.+\\.jsx?$": "./node_modules/babel-jest",
      "\\.(jpg|jpeg|png|gif|eot|otf|webp|svg|ttf|woff|woff2|mp4|webm|wav|mp3|m4a|aac|oga)$": "./app/js/__mocks__/fileTransformer.js"
    "testEnvironment": "jsdom",
    "roots": [
    "testRegex": ".*.test.js",
    "verbose": true

Note: The StackOverflow answer talks about a file called .babelrc I couldn’t find such file in OpenMRS ReactJS projects.

@jeiddiah @kingisaac95 @millicent Some help here please :slight_smile:

I found out that creating a new file in my root folder called ‘.babelrc’ was fixed the issue.

(I’m not sure whether this is okay according this OpenMRS OWA standards. @raff @dkayiwa)

Here is the answer:

@upendo @dkayiwa Thanks for trying to help me out! :slight_smile:

Thanks & Regards, Jude Niroshan

Thanks @dkayiwa. I haven’t used Jest for testing before. I currently use these tools: mocha, jasmine, chai, should for testing.

Awesome. ‘.babelrc’ is a configuration file and its also exists on the current OWA me and my team are working on.