JDK 7 is not working anymore in CI

So, turns out that’s way too EOL to get a decent support.

Related: Certificate Issues with new Maven Repo?

Since update 95, even the unsupported OpenJDK repository stopped supporting JDK 7 for Ubuntu 16.04.

I tried to get our JDK 7 to work again with our letsencrypt certificate. I tried every option under the zodiac I could find. We included the certificates to the truststore, tried all protocol options, and still, nothing seems to get maven with JDK 7 to talk to our maven repository.

Which means that JDK 7 doesn’t work anymore in our uilds.

If you want to check which builds are currently configured to use JDK 7: https://ci.openmrs.org/admin/agent/viewJdks.action

(Check ‘jobs’)

I won’t have time or energy to look for other alternatives. If there’s someone willing to find it, let me know how you did it locally, and I will adapt and automate that. Remember we have multiple JDKs on the same server, so it cannot break the supported ones.

@dkayiwa I know you’ll be interested in this.

Yes indeed! :smile:

I have done a rebuild for all on OpenJDK 8

The 1.9.x build failed. But i anyway just disabled it since 1.9.x is no longer supported.

1 Like