when executing automated tests using OMRS local instance with chrome web driver.[Resolved]

Hello here! I was trying to create a simulation of how we might check for XSS vulnerabilities in Reference Application 2.x, using selenium and cucumber, following the QA documentation guide.
However, I am failing to run tests from my local instance of OpenMRS using the SDK. I keep on getting an error, Unsupported or unrecognized SSL message when I changed the webapp.url to point to https://localhost:8080/openmrs/ i the file. But, however, using the qa-server works fine.

Is there a certificate i need to first install in chrome? How can i manually change the IP adress and the port where chrome driver is listening. (Please correct me if these arent the right solutions to this problem)

Thank you cc @kdaud @sharif @insookwa

Are you testing on local server or qa server

local server @sharif

How are you checking this xss vulnerabilty? , Are these changes on git hub such that we can look at the code .

1 Like

I was thinking of making a draft after polishing code. But since you want to take a look at the changes, XSS-Check-WIP: Inital attempt of automating tests for XSS check by jnsereko · Pull Request #132 · openmrs/openmrs-contrib-qaframework · GitHub

Sounds good, Have left a comment on the github which am thingking the error could have been from, Instantiating a driver inside a class is implicitly and arg

Not all!

You do not need to change neither the IP address nor the port. You need to ensure your chrome driver version your using is compatible with the chrome version(chrome driver version should be the same as that of the chrome browser) your running on your PC.

@jnsereko have you made any change in the module before running npm run refapp2FindPatient ?

Yes @kdaud, but I staged them first. Except for the file and the src/test/resources/chromedriver The QA-server is working fine but the local instance is not.

I also tried using firefox but am getting the same error.

I am using chrome Version 93.0.4577.63 and am sure its compatible with ChromeDriver 93.0.4577.63

1 Like

@jnsereko the snag is at the url your using for the local instance, it should be


Set the port to the one your local instance is running on if not 8080.

Hello @jnsereko , any progress on your local testing, probably building all three modules(uitestframework, refapp distro, qaframework) at once can save you perhaps, this enhances building of required dependencies

Ooohhh…! for local i should use http, not the secured https!

I am trying our @kdaud suggestion

1 Like

Ohh you are using secured Https, probably but i guess they should also work

1 Like

Honestly, I can’t tell what is going wrong. It hasn’t worked even now. I am optimistic, though.

@jnsereko use http when pointing to the local instance not https

@kdaud @sharif it is working fine now :slightly_smiling_face: Thank you so much

1 Like