java.lang.NoClassDefFoundError: while running latest openmrs snapshot version

FWIW, i have just done a sanity check by running the SDK to set up the latest reference application 2.8 Then stopped the sdk and replaced its openmrs-2.1.3.war file with that of the latest openmrs-core snapshot. Went into its modules folder and replaced the emrapi, coreapps, and webservices modules with the latest snapshot versions of each. Did run the sdk again and it took me to the setup wizard before bringing up the login screen with all modules running fine.

1 Like

really :grin:. may be i ddnt mind about the core apps version?

can u just attach for me the ( core-apps, emrapi, and webservices) omods that uve used to this ticket https://issues.openmrs.org/browse/TRUNK-5342??? it will save me a great deal of time

so that tomorrow i start on the few remaining work on the ticket…

otherwise , its three days now ,am hustling with getting a reffrence app sit on the platform 2.2.0

Just compile them from source. It is part of the work you will be doing for this ticket because the changes will go in almost all these modules.

1 Like

:rofl: :sunglasses: …ok sir :thinking:.

hi @dkayiwa i compiled the weservices.rest and emrapi , but have failed to compile the core apps . error here

Could you share the full log? @mozzy

here is the error

 Found proxies: [default{protocol='', host='proxy.host.net', port=80}]
[INFO] Installing node version v6.10.0
[INFO] Downloading https://nodejs.org/dist/v6.10.0/node-v6.10.0-win-x64.zip to C:\Users\Dell\.m2\repository\com\github\eirslett\node\6.10.0\node-6.10.0-win-x64.zip
[INFO] Downloading via proxy default{protocol='', host='proxy.host.net', port=80}
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO]
[INFO] Core Apps Module ................................... SUCCESS [  8.841 s]
[INFO] Core Apps Module API-pre2.2 ........................ SUCCESS [ 14.052 s]
[INFO] Core Apps Module API ............................... SUCCESS [ 16.864 s]
[INFO] coreapps Module web 1.9 ............................ SUCCESS [  0.865 s]
[INFO] coreapps Module web 2.0 ............................ SUCCESS [  1.014 s]
[INFO] Core Apps Module API 2.2 ........................... SUCCESS [ 16.798 s]
[INFO] Core Apps Module OMOD .............................. FAILURE [ 23.917 s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 01:39 min
[INFO] Finished at: 2018-06-29T08:49:16-06:00
[INFO] Final Memory: 54M/339M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal com.github.eirslett:frontend-maven-plugin:1.4:install-node-and-npm (install node and npm) on project coreapps-omod: Could not download Node.js: Could not download https://nodejs.org/dist/v6.10.0/node-v6.10.0-win-x64.zip: Unknown host proxy.host.net -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <goals> -rf :coreapps-omod

D:\openMrs\code\tickets\openmrs-module-coreapps>

i have tried to delete the dependece over and over but it fails

What does this command return? mvn -v

Do you already have npm installed or not? You could install it manually.

it returns this

 C:\Users\Dell>node -v
    v8.11.3

@wyclif , i have installed npm but using the windows installer.

am not sure whether installed it “on” the project as the error log says , but any way i installed it using the installer

What does this command return? npm -v

C:\Users\Dell>node -v
v8.11.3

C:\Users\Dell>npm -v
5.6.0

Now compile the module again with this command: mvn clean install -e

ok sir, let me do that

@dkayiwa here the error

https://pastebin.com/WvMGXxfe

Are you running this from command line? Or from your IDE?

i run it from either way, previuosly i was running it from commandline, that last attempt was from ecclipse

Can i look at the log when you compile from command line?