issue with "Reference Application 2.9.0"

Copy and place the above file in a file called openmrs-distro.properties
Then do

mvn openmrs-sdk:setup -Ddistro=path-to-distro-file\openmrs-distro.properties

Thanks a lot @mozzy @herbert24 @vankineenitawrun for the quick responses on this. I am trying with the OpenMRS SDK now. I will update the status here.

@krishnashetty0000 , we would like to hear from you if your problem has been solved because may be some other developers can also learn from you, or else add some contribution if neccessary. thanks .

1 Like

Hi, I continued this today. I got this error when I try to run “mvn openmrs-sdk:setup -Ddistro=path-to-distro-file\openmrs-distro.properties”. Any hints to fix?

mvn openmrs-sdk:help output

Try Running just mvn openmrs-sdk:setup

The error in the Log shows it as error from parsing the openmrs-distro.properties file.

@krishnashetty0000 , you were supposed to replace that with the actual path to your distro file

After the setup, I ran mvn openmrs-sdk:run -DserverId=myserverid

Got the error “…Establishing SSL connection without server’s identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn’t set…”

I added aded “&useSSL=false” to the DB connection UR.

I am able to see this screen:

Looks like there were errors, here is the logs

My requirements with the SDK:

What do I need to do to get there? Thanks a lot for helping

1 Like

Hi, Any hints to fix this and go to the next steps?

Hey in admin interface check manage module page try running install all modules

Thanks. Tried this, got below errors:

  • Error while trying to start module Module Registration App Module cannot be started because it requires the following module(s): coreapps 1.11.1 Please install and start these modules first.

  • Error while trying to start module Module Core Apps Module cannot be started because it requires the following module(s): emrapi 1.26.0 Please install and start these modules first.

  • Error while trying to start module Module Appointment Scheduling UI Module cannot be started because it requires the following module(s): coreapps 1.11.1 Please install and start these modules first.

And see these errors

I am installing the module versions as mentioned in the error logs. I will update the status here.

Check the modules folder of the respective server to see if all modules stated by @mozzy over here are present.

Thanks @haripriya

Facing an issue with the setup. I have described the issue a new thread: setting up OpenMRS SDK with Reference Application

Could you please check? Thank you.

Hi @krishnashetty0000 , that directly shows you ddint use the distro file i gave you , Its a bit tricky to get the reff app run on the latest core. You must use the right module versions. it was simply creating the distro file i gave you and build the ref app distribution from that very fle, because i personally had to go through alot to get the right distro-file that can run on the latest core

This seems to be completely another error. Now lets go back to the roots a little bit

What exactly do you want to do ?? as in what is the exact use case for this?? besides there are simpler ways of running the openmrs instance without going into alot of issues, e.g simply running the Standalone app.

Hi @mozzy, thanks I have responded in the other thread.

Issue resolved: I just had to change the “coreapps” version to 1.11.1 and “emrapi” version to 1.26.0 in the distro file given by @mozzy. Thanks a lot

3 Likes

great @krishnashetty0000

1 Like