issue with atom-feed module.

Hi All

I am trying to start the atom feed module locally. And am getting below error which seems to be an issue on mysql version and liquibase incompatibility.

Local mysql version :- 5.7.

I tried by creating tables separately in mysql but it’s giving another error. Any idea would be much appreciated :slightly_smiling_face:

Do I have to downgrade mysql version to 5.6 ?

@ayesh I tried it with MySQL version 5.6 its working without any errors. I guess you’ll need to install MySQL 5.6 version

1 Like

Cool let me try downgrading mysql

Yeah its working perfectly. But will be very painful since 5.6 is not directly supported in Ubuntu 16.04 + onwards

Still there is docker compose with a volume for anyones help else you have to follow the hard way

But am not quite sure why it’s not supporting mysql 5.7 which other most of the modules working. Maybe we can take a look on it.

cc :- @dkayiwa @ibacher

@Ayesh Could you open a ticket for this? Basically MySQL 5.7 by default runs in strict mode and rejects a non-nullable TIMESTAMP column without a default value. This can probably be fixed by changing the definition here to:

<column name="date_created" type="timestamp" defaultValueDate="CURRENT_TIMESTAMP" />

And adding the current checksum as a <validCheckSum>.

Are you sure that you are running the latest version of this module? This was fixed some time back.

Hi @ibacher

Yeah I even disabled the strict run as below guide says

And yes changed the definition to

   <column name="date_created" type="timestamp" defaultValueDate="CURRENT_TIMESTAMP" />

Because In the installed distribution server I found another liquibase using this as the default value for the timestamp column.But it was the same.

But I will check again with the new definition for the column.


Yeah am building from source which means it’s in latest snapshot

FWIW am running the snapshot version of the module successfully on Server version: 5.7.16 MySQL Community Server (GPL)

hmm is the strict mode disabled ? Because am still getting the same issue with 5.7