Issue while Setting up 1.9.8 on MAC

org.openmrs.module.ModuleException: Unable to start OpenMRS. Error thrown was: The following modules are marked as ‘core’ by OpenMRS but were unable to start: logic v0.5.2,

Hi @navnit what are steps you did to encounter this issue?

below are the steps

git clone --branch 1.9.8 https://github.com/openmrs/openmrs-core.git

mvn clean (worked) mvn install (failed with below errors)

ERROR - JDBCExceptionReporter.logExceptions(234) |2017-03-26 21:41:02,483| Unique index or primary key violation: “CONSTRAINT_INDEX_24 ON PUBLIC.SCHEDULER_TASK_CONFIG(UUID)”; SQL statement: insert into scheduler_task_config (task_config_id, uuid, name, description, schedulable_class, repeat_interval, start_time, start_time_pattern, last_execution_time, start_on_startup, started, created_by, changed_by, date_created, date_changed) values (null, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?) [23001-135]

ERROR - OpenmrsUtil.toPatientFilter(1794) |2017-03-26 21:41:52,487| class org.openmrs.reporting.ProgramStatePatientFilter . program should be class org.openmrs.Program but is given as class java.lang.Integer

Running org.openmrs.api.handler.EncounterSaveHandlerTest ERROR - EncounterSaveHandler.handle(51) |2017-03-26 21:42:09,890| Unable to save complex obs java.lang.NullPointerException

Running org.openmrs.report.PepfarReportSerializationTest <conceptClass id=“1” conceptClassId=“123”/> ERROR - PatientSearch.createCompositionSearch(214) |2017-03-26 21:42:32,931| Error in token list java.lang.IllegalArgumentException: Unrecognized string token: male

clean install -DskipTests Deployed war on Tomcat 8 Started Tomcat

I assume you’re intentionally running an old no-longer supported OpenMRS release.

Did you try doing what that error message says, e.g. adding the logic module (at least version 0.5.2)?

Hi Darius,

The Project we are working on is built upon OpenMRS 1.9.8 as specs.

No, didnt tried it as setup is working fine on windows.

Guys! This particular problem is resolved with downgrading JAVA version to 7.

Appreciate your help :slight_smile:

However facing this issue now

ERROR - TimerSchedulerTask.run(54) |2017-03-28 12:57:27,100| FATAL ERROR: Task [class org.openmrs.scheduler.tasks.TaskThreadedInitializationWrapper] failed due to exception [org.openmrs.api.APIException] org.openmrs.api.APIException: Service not found: interface org.openmrs.logic.token.TokenService