Issue while installing Bahmni v0.92 on centos(7.6)

Also make sure you install appropriate zlib library. Please check the prerequisites section in the release notes in WIKI. (or even the installation page)

1 Like

what should be th zlib version?

yum install -y https: //kojipkgs .fedoraproject.org //packages/zlib/1 .2.11 /19 .fc30 /x86_64/zlib-1 .2.11-19.fc30.x86_64.rpm

i did that buvaneswariarun if i run bahmni – help that error will appear thanks

Got the error of No module named click and solved after the install of Click 7.0, but error on odoo “unable to start service odoo” and unable to install odoo.

@laxman @angshuonline @buvaneswariarun

Please give the command pip install pyusb and then give a bahmni -i local install – this issue is because of a missing distribution in python pip

Thank you for the prompt reply @buvaneswariarun, I have installed manually pyusb, but after that one after another python module error occur during installation.

“odoo 10.0.post20190619 requires ofxparse, which is not installed. odoo 10.0.post20190619 requires passlib, which is not installed. odoo 10.0.post20190619 requires psycogreen, which is not installed. odoo 10.0.post20190619 requires pypdf, which is not installed. odoo 10.0.post20190619 requires pyserial, which is not installed. odoo 10.0.post20190619 requires python-chart, which is not installed. odoo 10.0.post20190619 has requirement babel>=1.0, but you’ll have babel 0.9.6 which is incompatible.”

Is it your local machine? If so, can you try this sequence? yum install https://kojipkgs.fedoraproject.org//packages/zlib/1.2.11/18.fc30/x86_64/zlib-1.2.11-18.fc30.x86_64.rp sudo yum install epel-release [[If not already present]] pip install pyusb yum install <rpm_name>

@buvaneswariarun Its my local machine. Already installed the zlib by following WIKI and installed epel-release, pyusb and another error of module “pkg_resources.DistributionNotFound: The ‘pypdf’ distribution was not found and is required by odoo”, in the same way install of pypdf another module error occur.

I am assuming. that this is your local vagrant - Can you try removing the installed bahmni and try again installing?

I have tried on both physical machine and on virtual machine many time, but same error occur in both instance as we are going to implement the Bahmni 0.92 on our one of the new hub, so need to resolve this error as soon as possible.

If you can try these steps one last time as a fresh installation and share the logs, it would be easy for us to investigate. In the community many asserted that pip install pyusb was sufficient to go ahead with the installation - need to investigate why you are not going through. You can also try pip uninstall pip and then pip install pip before trying pyusb command

Start with the fresh Centos OS and error of “[root@localhost ~]# bahmni --help Traceback (most recent call last): File “/usr/bin/bahmni”, line 9, in load_entry_point(‘bahmni==0.1’, ‘console_scripts’, ‘bahmni’)() File “/usr/lib/python2.7/site-packages/pkg_resources.py”, line 378, in load_entry_point return get_distribution(dist).load_entry_point(group, name) File “/usr/lib/python2.7/site-packages/pkg_resources.py”, line 2566, in load_entry_point return ep.load() File “/usr/lib/python2.7/site-packages/pkg_resources.py”, line 2260, in load entry = import(self.module_name, globals(),globals(), [‘name’]) File “build/bdist.linux-x86_64/egg/bahmni.py”, line 1, in ImportError: No module named click”

@buvaneswariarun Tried with the fresh installation as per the instruction but stuck on the installation of same python module error and no progress on installation. Installed the pyusb manually and after the " pkg_resources.DistributionNotFound: The ‘pyserial’ distribution was not found and is required by odoo" error.

@buvaneswariarun Struggled to install bahmni successfully. Have to install so many python modules manually:

pip install pyusb
pip install ofxparse
pip install passlib
pip install pypdf
pip insall pyserial
pip install pyserial
pip install python-chart
pip uninstall babel
pip install babel
pip install psycogreen
pip install urllib3
pip install certiti
pip install certifi
pip install chardet
pip uninstall chardet
pip install chardet
pip uninstall idna
pip install idna

Need to install to resolve the odoo UI display error :
 sudo npm install -g less@3.0.4 less-plugin-clean-css
1 Like

Thanks for letting us know. Will investigate and come out with a better way of dealing with this.

1 Like

great work @utsavdeshar , I suggest this should be taken care by the community for future ease of installation.

@buvaneswariarun I tried @utsavdeshar’s steps but I get below error when I try installing psycogreen

Collecting psycogreen
  Using cached https://files.pythonhosted.org/packages/eb/72/4a7965cf54e341006ad74cdc72cd6572c789bc4f4e3fadc78672f1fbcfbd/psycogreen-1.0.2.tar.gz
  Installing build dependencies ... done
  Getting requirements to build wheel ... error
  Complete output from command /usr/bin/python2 /usr/lib/python2.7/site-packages/pip/_vendor/pep517/_in_process.py get_requires_for_build_wheel /tmp/tmpHPKZis:
  Traceback (most recent call last):
    File "/usr/lib/python2.7/site-packages/pip/_vendor/pep517/_in_process.py", line 207, in <module>
      main()
    File "/usr/lib/python2.7/site-packages/pip/_vendor/pep517/_in_process.py", line 197, in main
      json_out['return_val'] = hook(**hook_input['kwargs'])
    File "/usr/lib/python2.7/site-packages/pip/_vendor/pep517/_in_process.py", line 54, in get_requires_for_build_wheel
      return hook(config_settings)
    File "/tmp/pip-build-env-VH5Beh/overlay/lib/python2.7/site-packages/setuptools/build_meta.py", line 146, in get_requires_for_build_wheel
      return self._get_build_requires(config_settings, requirements=['wheel'])
    File "/tmp/pip-build-env-VH5Beh/overlay/lib/python2.7/site-packages/setuptools/build_meta.py", line 127, in _get_build_requires
      self.run_setup()
    File "/tmp/pip-build-env-VH5Beh/overlay/lib/python2.7/site-packages/setuptools/build_meta.py", line 142, in run_setup
      exec(compile(code, __file__, 'exec'), locals())
    File "setup.py", line 11, in <module>
      from psycogreen import __version__
  ImportError: No module named psycogreen

Download the psycogreen from the below link and follow the step to install package: > wget https://files.pythonhosted.org/packages/eb/72/4a7965cf54e341006ad74cdc72cd6572c789bc4f4e3fadc78672f1fbcfbd/psycogreen-1.0.2.tar.gz

    tar -xvf psycogreen-1.0.2.tar.gz
    cd psycogreen-1.0.2
    python setup.py install
1 Like

Thanks this worked