Issue setting up legacy-ui development environment

I am on macos and have made a couple minor changes to the legacy-ui module. The openmrs-core instance is running. I have run maven clean install on the legacy-ui and copied the omod into the modules folder in my .OpenMRS/modules folder. The module previously worked, but now when I open the browser, I get the “No UI modules are installed” message. I tried reverting my changes and using the original omod, but now it no longer works. I reset my OpenMRS instance and reinstalled it. I even tried adding the original reference application module, but nothing has solved this issue and it is still unable to detect any modules.

Thank you for any help. I’m quite stuck on this problem and have been trying to solve it for almost a day now.

If you can’t figure out any solution for my problem, is there a way to completely reset my OpenMRS instance and start from scratch?

While your mouse is on the address bar, try press CTRL + SHIFT + R

I have already tried that as well. (Sorry I forgot to mention it)

If clearing your browser cache has not worked, then paste the server logs at

Apologies for the delay @dkayiwa . Sunday is my day off from programming. Here is the server log:

What do you have in this folder? /Users/whitaker/.OpenMRS/modules

The omod file named legacyui-1.4.0-SNAPSHOT.omod

Can you try a different browser?

I just did and the UI still fails to show up.

What do you mean by the UI fails to show up?

Sorry, I should have been more clear. I mean it still gives the message that states that no user interface module is installed.

What value is returned by this sql statement when run against your database?

select property_value from global_property where property = “legacyui.started”

It returns false

Set its value to true

Then run OpenMRS again and tell us what happens.

Aha! That was the trick. The UI is loading now. Just as a learning experience for me, what does that do for the server exactly? Does it just tell the server that the module is there and ready to be loaded? Thank you so much! :smile:

A module can be installed but not started (not running). So setting that flag to true makes the module run on startup. Because you did not explicitly stop that module, there is possibly a bug somewhere that stopped it.

Good to know. Thank you again.