Installing OpenMRS: Tomcat Failure: Failed to start component


I need a help in fixing this Tomcat failure while deploying openmrs.war. I tried the various suggestions on web, but it did not solve the issue. I am trying to deploy through the manager UI of tomcat - http://:8080/manager

Tomcat : 10.1.7 MySQL : 8.0.32

Tomcat error:

30-Mar-2023 23:54:05.174 SEVERE [http-nio-8080-exec-5] org.apache.catalina.startup.HostConfig.deployWAR Error deploying web application archive [/opt/tomcat/webapps/openmrs.war] java.lang.IllegalStateException: Error starting child

Caused by: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/openmrs]]

As a new user, I am not able to upload the complete log in this topic. Any input will help?

Regards Yesudian Rajkumar

We only support up to Tomcat 9 at present, so you’ll have to downgrade this.

Sure, thanks for the confirmation. I will downgrade and update here.

I could install openmrs using the below: jdk 1.8, tomcat9 on ubuntu 20.04.

However, I am still stuck at the OpenMRS initialization where it is throwing the below error: ???Error executing sql: create database if not exists ? default character set utf8

When I first ran the wizard (with demo data), It looks it has created the database and the user. Tasks completed so far: Created database openmrs Created user openmrs_user Granted user openmrs_user all privileges to database openmrs Created database tables and added core data Saved runtime properties file /var/lib/OpenMRS/ Adjusting file posix properties to user readonly Successfully adjusted RuntimePropertiesFile to disallow world to read it

Next time, I ran excluding the demo data option and started getting the error - ???Error executing sql: create database if not exists ? default character set utf8

I checked the mysql credentials and it is correct.

Do you have any further inputs on this?

After I restart the system, I managed to reach the OpenMRS login page.