installing mysql server 5.7


(George Junior Kamugasha) #1

i installed but mysql 5.7 but it’s not being recogonized… where could the problem be? @odorajonathan @herbert24


(Herbert Yiga) #2

look for your installation folder called MySQL,then get to the bin folder then run your command for example C:\Program Files\MySQL\MySQL Server 5.6\bin>mysql -u root -p


(George Junior Kamugasha) #3

it is giving me this result

C:\Users\Admin>C:\Program Files\MySQL\MySQL Server 5.7\bin>mysql -u georgejr -p ‘C:\Program’ is not recognized as an internal or external command, operable program or batch file.


(JONATHAN AJAL ODORA) #4

@georgejr have you clicked on the button just below MySQL connections? What is the output? because it must let you to a login to your database.


(George Junior Kamugasha) #5

thats wat it shows me


(JONATHAN AJAL ODORA) #6

yes your MySQL is okay then.


(Herbert Yiga) #7

i was just giving you an example,just look for your mysql installation folder,then get the path of the bin folder,from that point you will be able to acces the database


(George Junior Kamugasha) #8

@herbert24 @odorajonathan it has finally worked

i typed on my cmd “C:\Program Files\MySQL\MySQL Server 5.7\bin>mysql -u root -p” and then entered password.


(Herbert Yiga) #9

okay then thats awesome!!


(George Junior Kamugasha) #10

@herbert24 @dkayiwa @odorajonathan this is what i got when trying to run the server

https://pastebin.com/3Duw2A8a


(JONATHAN AJAL ODORA) #11

@georgejr Did you already set your MySQL for example with wamp or xamp prior to setting up the server?


(Juliet Wamalwa) #12

@georgejr is RefApp 2.9.0 is not released yet choose a lower version.


(George Junior Kamugasha) #13

let me try that


(George Junior Kamugasha) #14

yeah i did


(JONATHAN AJAL ODORA) #15

first try what @jwnasambu is saying and we see, could the solution


(Herbert Yiga) #16

@geargejr according to your logs,i am seeing your connectiong to root as the database.did you create any database called root?


(tendo kiiza Martyn) #17

@georgejr what are the contents mysql config file ?

did you look into " Failed to connect to the specified database jdbc:mysql://localhost:3306/root?autoReconnect=true&sessionVariables=default_storage_engine%3DInnoDB&useUnicode=true&characterEncoding=UTF-8 ->"

and The distribution requires MySQL database. Please specify database uri (-DdbUri) (default: ‘jdbc:mysql://localhost:3306/@DBNAME@’): jdbc:mysql://localhost:3306/root


(Juliet Wamalwa) #18

This is his error https://pastebin.com/3Duw2A8a


(George Junior Kamugasha) #19

@jwnasambu i tried doing this but it still failed


(George Junior Kamugasha) #20

@tendomart i don’t understand this result Failed to connect to the specified database jdbc:mysql://localhost:3306/root?autoReconnect=true&sessionVariables=default_storage_engine%3DInnoDB&useUnicode=true&characterEncoding=UTF-8 ->

for this ( The distribution requires MySQL database. Please specify database uri (-DdbUri) (default: ‘jdbc:mysql://localhost:3306/@DBNAME@’): jdbc:mysql://localhost:3306/root), i tried to run without “root” but it didn’t work out well.