Installing legacy UI

Hello,

I have successfully cloned, built and run (with commands mvn clean install and mvn jetty:run) openmrs-core. I also followed the instructions for developers here: https://wiki.openmrs.org/display/docs/User+Interface+Modules but got stuck on point “3. Install the module”. Where am I supposed to put legacyui-{versionNumber}.omod file? I don’ t have OpenMrs->module folder in my local files opened by running %APPDATA%.

Can you share your tomcat log file contents at pastebin.com?

https://pastebin.com/xCrFRbuJ

Do you have any other log files like catalina?

Sorry, I missed them. There are 2 more files, the rest is empty. Localhost: https://pastebin.com/FjcR4Trj The day’s before catalina: https://pastebin.com/FbHmUFG4

Stop tomcat, delete all logs, then start tomcat and reproduce the problem. Send contents of the log files.

Hi I’ve copied the legacy ui to .OpenMRS/modules directory. Yet I see the " If you are seeing this page, it means that the OpenMRS Platform is running successfully, but no user interface module is installed. Learn about the available User Interface Modules

If you are a developer, you can access the REST API. (See REST documentation for clients)"

Any suggestions?

Thanks

Can you try clear the browser cache?

It’s still the same. omod file is in the modules directory

What happens when you put the cursor in the browser address bar and then press? CTRL + SHIFT + R

reloading changes nothing. Is there a log file that I can check to see if the module gets a hit?

Which server are you using… Try stopping it and restarting it… After you have added the UI omod to that location for modules

Hi Reagan,

I’ve tried that multiple times with no luck. Any more suggestions? I’m running MacOS Mojave.

how are you restarting your server?

Can you paste the contents of the tomcat log file at pastebin.com?

I would suggest u try out this. “On where to place the legacyui.omod files , I first placed them in ${HOME}/.OpenMRS/modules) and it showed an error. However on placing them it in the /webapp/openmrs/WEB-INF/bundledModules folder the application ran perfectly.”

from the tomcat folder

This is not recommended because they get overridden every time you redeploy the web app.

1 Like

Thanks for this correction. was not certain about it. :slightly_smiling_face:

Hello @dulvinw are you still getting the same error? I had to restart my server (mvn jetty:run). This cleared the error if you’ve correctly copied the .omod files as outlined in the developers manual.