Installing Bahmni In docker

Hello I’m trying to install bahmni into docker i have tried serveral time with centos and windows but i keep
getting this error when starting services

dependency failed to start: container bahmni-standard-odoodb-1 is unhealthy

Here is what happen when i’m launching through the

[root@localhost bahmni-standard]# ./ Docker version >= 20.10.13, using Docker Compose V2 Docker Compose version: Docker Compose version v2.24.5

bahmni-standard Please select an option:

  1. START Bahmni services
  2. STOP Bahmni services
  3. LOGS: Show OpenMRS Logs
  4. LOGS: Show LOGS of a service
  5. SSH into a Container
  6. START Bahmni Analytics (Mart and Metabase)
  7. PULL latest images from Docker hub for Bahmni
  8. RESET and ERASE All Volumes/Databases from docker!
  9. RESTART a service
  10. STATUS of all services

1 Executing command: ‘docker compose up -d’ with the images specified in the .env file Starting Bahmni with default profile from .env file [+] Running 15/35 ⠴ Network bahmni-standard_default Created 56.5s ⠇ Volume “bahmni-standard_sms-token” Created 55.8s ⠇ Volume “bahmni-standard_bahmni-queued-reports” Created 55.8s ⠧ Volume “bahmni-standard_odoodbdata” Created 55.7s ⠧ Volume “bahmni-standard_odooappdata” Created 55.7s ⠧ Volume “bahmni-standard_openmrsdbdata” Created 55.7s ⠧ Volume “bahmni-standard_openelisdbdata” Created 55.7s ⠦ Volume “bahmni-standard_bahmni-lab-results” Created 55.6s ⠦ Volume “bahmni-standard_bahmni-config” Created 55.6s ⠦ Volume “bahmni-standard_bahmni-patient-images” Created 55.6s ⠦ Volume “bahmni-standard_bahmni-uploaded-files” Created 55.6s ⠦ Volume “bahmni-standard_bahmni-clinical-forms” Created 55.6s ⠦ Volume “bahmni-standard_bahmni-document-images” Created 55.6s ⠦ Volume “bahmni-standard_configuration_checksums” Created 55.6s ⠴ Volume “bahmni-standard_pacsdbdata” Created 55.5s ⠴ Volume “bahmni-standard_dcm4chee-archive” Created 55.5s ⠴ Volume “bahmni-standard_reportsdbdata” Created 55.5s :heavy_check_mark: Container bahmni-standard-pacsdb-1 Started 8.4s :heavy_check_mark: Container bahmni-standard-proxy-1 Started 7.2s :heavy_check_mark: Container bahmni-standard-bahmni-web-1 Started 3.3s :heavy_check_mark: Container bahmni-standard-bahmni-config-1 Started 3.4s :heavy_check_mark: Container bahmni-standard-reportsdb-1 Started 5.6s ✘ Container bahmni-standard-openelisdb-1 Error 55.5s :heavy_check_mark: Container bahmni-standard-openmrsdb-1 Started 3.1s ✘ Container bahmni-standard-odoodb-1 Error 39.9s :heavy_check_mark: Container bahmni-standard-pacs-integration-1 Started 6.9s :heavy_check_mark: Container bahmni-standard-appointments-1 Started 3.2s :heavy_check_mark: Container bahmni-standard-dcm4chee-1 Started 5.2s ⠏ Container bahmni-standard-odoo-connect-1 Created 54.9s ⠏ Container bahmni-standard-odoo-1 Created 54.9s :heavy_check_mark: Container bahmni-standard-openmrs-1 Started 10.2s :heavy_check_mark: Container bahmni-standard-reports-1 Started 10.0s ⠇ Container bahmni-standard-openelis-1 Created 54.8s :heavy_check_mark: Container bahmni-standard-patient-documents-1 Started 11.9s :heavy_check_mark: Container bahmni-standard-implementer-interface-1 Started 11.9s dependency failed to start: container bahmni-standard-odoodb-1 is unhealthy

What am I doing Wrong please

It seems ur database containers for Lab (Openelis) and Odoo (DB) didn’t start. Other containers for Bahmni – EMR seem to be up and running.

You can run option 10 (STATUS OF ALL SERVICES) to see which services are up and running and which are not.

Then u can do look at option 4 (SHOW LOGS) to see the logs of openelisdb and odoodb service, to see what error is thrown while starting the DB. Is there some port which is conflicting on your machine, that is causing DB issues, or did Datbase have some errors while starting up, etc.

Which OS are your trying this in?

Hello @gsluthra thanks for taking time to assist, I have tried through CentOS 7.9 and Windows 10 same Issue Currently i’m On centos 7.9

As in the image the container is now showing Healthy

But odoo is not showing up when i’m clicking on STOCK INVENTORY AND BILLLING

I will just wait and see if it starts properly

Please retry with latest Bahmni images

  1. Rename .dev.env file to .env.
  2. docker compose pull (to pull all latest images)
  3. Restart Bahmni.
  4. See Odoo Logs to see if it starts fine, or has errors.

do these
docker compose restart proxy odoodb odoo
docker compose ps -a on status it should UP
Generally services take time to boot