Initial Installing OpenMRS

Hello community. I am trying to install OpenMRS on my PC but the database is giving me an error hence limiting the creation of the database in OpenMRS. How can I go about this error?

Kindly share the error you are getting through pastebin.

hello, i am trying to build OpenMrs on my pc in eclipse but i am getting an error. Can anyone help me with this?

The full error message:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.22.2:test (default-test) on project openmrs-api: There are test failures.


[ERROR] Please refer to /Users/ashutoshdubey/openmrs-core/api/target/surefire-reports for the individual test results.

[ERROR] Please refer to dump files (if any exist) [date].dump, [date]-jvmRun[N].dump and [date].dumpstream.

[ERROR] → [Help 1]


[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.

[ERROR] Re-run Maven using the -X switch to enable full debug logging.


[ERROR] For more information about the errors and possible solutions, please read the following articles:

[ERROR] [Help 1]

Oh sorry for the error. Kindly how are you building the project?

I am trying to build using maven clean install in eclipse and also tried doing “-U clean install” but it is giving me the same error.

Is the build failure on your branch or master branch? If it’s on your branch kindly the cause could be due to the changes you have incorporated.

it’s the main branch, this is the first time i am setting the development environment.

Yah it does happen. Kindly share the entire error logs using pastebin on your terminal.

sKKAwydy.txt (2.1 KB)

Oh sorry! you just shared part of the logs. Kindly share the last line on your terminal.

I am not sure what you are talking about, I only have the console log. tknF7WJs.txt (2.1 KB)

You have missed it out again. No worries kindly we can meet on this link before I drop off

Its unfortunate you are using java 17 which is not supported by openmrs. Kindly downgrade to any version from 8 - 15.

1 Like

Thanks for the help.