Importing Metadata using metadata sharing module, CIEL Database

Hi all, In our project we have developed our concepts (1000s of them), then we decided to import the CIEL database. The CIEL database from dropbox will replace all concepts tables that we have. So we decided to export our concepts first using metadata sharing module, then import the CIEL concepts to our MYSQL. after that we imported our concepts back again using the metadata sharing module. Unfortunately, we have encountered the following error

I appreciate any advice in terms of how to solve the current issue on hand. I realized that many of the CIEL concepts have the same ID of the concepts that we developed. I am not sure how is it possible to keep all concepts and change the ID of the CIEL ones.


Which version of the module are you using?

You are amazingly fast to reply @dkayiwa thanks very much for that. It is metadata sharing 1.1.10

Use version 1.2

Just to check, you’re not doing this against a database with observations in it, are you? It is not okay to replace your legacy concept dictionary with CIEL, if you have existing obs, because it will change their meaning.

I have only one test patient with one vitals obs … I am I in trouble @darius

You are right @dkayiwa . I replaced the current version with 1.2 and I dont see the error anymore. This is great. However, while I am finishing the import, I was stuck on page 5. I reviewed all assessment and tried to click “load next part” but it does not seem to work.

Any suggestions @dkayiwa and @darius

thanks again

You need to share the logs to see what is going on.

here you go openmrs logs

when i clicked on part 1 … I got this error Thanks again @dkayiwa

@dkayiwa is there any thing I can do ?

You need to provide what is in the tomcat log files.

Here you go @dkayiwa first one:

second one:

Thanks again

@yadamz try set the correct values for these global properties or settings: scheduler.username & scheduler.password After saving, repeat the whole importation process.

@dkayiwa I tried it again however it didnt work. same result

However, what I did is trying to import smaller number of concepts (five instead of 1000s) . it worked fine. I imported the concepts successfully. is there a limit of how many concepts I can import?

@dkayiwa I tried 300 concepts and I ended up with this error

Task details

Failed (errors: 1)

Sun May 15 12:13:56 PDT 2016 - Saving import state Sun May 15 12:13:56 PDT 2016 - Importing subpackage 1 of 1 Sun May 15 12:13:56 PDT 2016 - Resolving related items Sun May 15 12:14:06 PDT 2016 - Adjusting import settings Sun May 15 12:14:06 PDT 2016 - Loading existing items Sun May 15 12:14:07 PDT 2016 - Converting items Sun May 15 12:14:07 PDT 2016 - Setting audit fields Sun May 15 12:14:08 PDT 2016 - Merging items Sun May 15 12:14:08 PDT 2016 - Preparing items to save Sun May 15 12:14:08 PDT 2016 - Validating items Sun May 15 12:20:44 PDT 2016 - Saving items Sun May 15 12:28:49 PDT 2016 - Updating mappings Sun May 15 12:28:54 PDT 2016 - Import completed Sun May 15 12:28:56 PDT 2016 - Task failed

org.openmrs.module.metadatasharing.task.TaskException: Task failed at org.openmrs.module.metadatasharing.task.Task.log( at org.openmrs.module.metadatasharing.task.TaskEngine$ at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$ Source) at Source) Caused by: org.openmrs.module.metadatasharing.task.TaskException: Task failed … 4 more Caused by: org.springframework.transaction.UnexpectedRollbackException: Transaction rolled back because it has been marked as rollback-only at at org.springframework.transaction.interceptor.TransactionAspectSupport.commitTransactionAfterReturning( at org.springframework.transaction.interceptor.TransactionAspectSupport.invokeWithinTransaction( at org.springframework.transaction.interceptor.TransactionInterceptor.invoke( at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed( at org.springframework.aop.framework.JdkDynamicAopProxy.invoke( at com.sun.proxy.$Proxy254.executeTask(Unknown Source) at org.openmrs.module.metadatasharing.task.TaskEngine$ … 3 more

Did you get a solution to your last issue? am having similar problem when importing a MDS with containing concepts

@ningosi Can you add org.openmrs.module.metadatasharing:debug to the Log global property so that you can see what is actually causing the errors

FYI, there are some outstanding issues with a few concepts which fail validation. I presume this is not an interacting issue.

I tried that, I never got something relevant that could lead me to the error that is causing the problem.