Implementer Interface (Form Builder) Getting concepts name as “Fully Specified Name”

I am creating observation form using implementer interface in bahmni 0.90. I am getting the concepts name as “Fully Specified Name”

I am able to edit the “Label Name” but not the “Answers name”. I tried this in Bahmni 0.89, Bahmni 0.90 and in Bahmni Demo Concepts

I am getting “Fully Specified Name” for answers and am not able to edit the Name. FSCN Concept

Go to implementer interface => Form builder => list of forms Click on the “internationalize” icon against that form, which will show you the Keys for each answer and the available names for the answer concepts. For each concept, list of all names for a given locale is shown. Choose one or just type out what you want.

Ideally, you want to create different synonyms for a concept! (I not necessarily agree with your concept name definitions, but thats a different thing)

Note: Although the observation forms will show whatever synonym you have defined, the dashboard will only show observations only in the FSN or short name of that locale.

Example: If I define a concept “supine” and another synonym “lying face upwards” (or just add a text dynamically) and pick “lying face upwards” to be displayed in the form - the form will display just fine. However, the observation display controls may not display “lying face upwards”. Since the observation values do not capture the synonym and just the reference, it is not possible to know what was the synonym that was displayed. So choose your concept name definitions carefully and also for reporting.

Thanks @angshuonline. That was helpful.

I did the changes in internationalize and i am able to see the changes in Bahmni online. image Bahmni Online image

But in Bahmni Connect PWA and in Android apk (0.90) its not working

Bahmni Connect PWA image

Bahmni Connect Android App 0.90 image

Is there ant suggestion that i need to follow to see the reflection of internationalize in Bahmni Connect.

Have you tried to resync the data. Maybe try to clean up the connect databases and try again?

btw, I think Connect only allows the default locale usage.