I get a Build Failure on compiling a newly cloned version

Tags: #<Tag:0x00007fdb709e8df8>

Hello All :wave: I have cloned openmrs-core. I have not changed anything yet.
When i run the command mvn clean package or the command mvn clean install, i get build failures as shown in the screen-shot below

How best can i resolve such an error?

1 Like

have you pulled the latest changes on core ie using git pull

@herbert24 yes i have pulled the latest changes before i asked this question

There are some test failures causing the build to fail.

If you’re okay with experimenting a little, you can try building without executing the tests, till they are fixed,

mvn clean install -DskipTests

If there were tests to fix, CI would not be green: https://ci.openmrs.org/browse/TRUNK-MASTER/latest

What does this command return? mvn -v

@dkayiwa What does this command return? mvn -v

Can you paste the full compile log at pastebin.com?

I am sorry to ask this but do you mean that i should paste the files i cloned in the pastebin or you mean something else?

The logs generated in the command prompt when you run mvn clean package or mvn clean install.

you mean the screenshots like this one

Yes, everything from the start (after mvn clean install) you can do that by redirecting the standard output and error to a log file,

mvn clean install > log 2>&1

Ok now i understand. thanks for the explanation :hugs: :hugs:

@captaindavinci mvn clean install -DskipTests

I get build success when i skip tests as shown in the screen shot below.

Can you share the full compile log? As @dkayiwa said the CI shows all tests are passing.

@captaindavinci; Am currently running mvn clean package command . The moment it finishes, i am going to paste the log in parsebin.com as @dkayiwa told me.

i will also paste the log of the command mvn clean install -DskipTests, If want me to do so :wink: :wink:

@dkayiwa, @captaindavinci i have tried to add the compile log but the information at the top is missing because of a reason i am not aware of. May be its a problem with my computer :roll_eyes: :roll_eyes: But the problem is that i cant paste all of it because i use more than the amount of space provided. and the site requests me to go PRO with dome dollars i currently dont have. How best can i go over this problem

@jnsereko Can you upload the log file here?

log.txt (845.9 KB) That is the file having a copy of all that was present in the command prompt. I selected all that was present in the command prompt.

Do you mind taking a look at https://www.youtube.com/watch?v=oCS0kU5VFA4. Use the free version other than the PRO

1 Like