I cant search for concepts on web browser

Hello all, I have a problem with searching concepts on Concept maintenance page and patient registration page. If I use web browser, I cannot add patient relatives or search for concepts. But if I login directly on my server (localhost instead of web address), it functions normally. I tried all the usually stuff like cleaning the cash, changing the browser, changing the computer , nothing worked.

Any idea on what did I do wrong :slight_smile: ?

Concept Maintenance page

Patient registration page

Here is the Logs https://pastebin.com/EL8sY1u2

Are you sure you are connecting to the same server? The logs you sent do not look complete.

Yes … It is the same server. :slight_smile: I am not sure if it is tomcat issue

Then the error could be in the logs.

will find and post

OK @dkayiwa here is the log files. there are three issues: I cant search for concepts on web browser, reference metadata module does not start, and coded concepts does not show on coreapps widgets. :slight_smile:

https://pastebin.com/X96sy5Yg

https://pastebin.com/9Q34Dp7h

Thanks again

Which version of the reference application are you using?

@dkayiwa it is 2.6

Upgrade the coreapps module as @ssmusoke said on the other thread.

will do and let you know

hello @dkayiwa I have updated the coreapp. It solved the coded concept problem. However, the Reference metadata module is still NOT working. I received a message that “unable to start module”

here is the logs

https://pastebin.com/uz0sb8sa https://pastebin.com/FtDUXgpJ

Thanks again for your support

You are getting this error because you already have a patient identifier type with uuid “05a29f94-c0ed-11e2-94be-8c13b969e334” whose name is not “OpenMRS ID”

The reference metadata is working :slight_smile:

@dkayiwa I realised that the Reference Metadata Module in my current live server is not working. It has been used for almost 2 years. My question is Do I actually needs this module, what does it do ?

Simply saying that it is not working, is not helpful. :slight_smile:

@dkayiwa It is working after I fixed the ID gen … I edited the post … sorry. But in my previous implmentation, it was not… Do I need it ? Does it do any critical functions

You will tell that by seeing what happens after removing it. :smile:

@dkayiwa I have been using one implmentation for 2 years with reference metadata module stopped. I didnt notice anything. I got it working now in my test installation, and I started to have errors… I will post them soon…

here @dkayiwa So I started Reference Metadata module. Then I tried to document on one of the forms from patient dashboard. Once I click on any form (developed by html form entry), I ends up with the following framework error

https://pastebin.com/YKb47pqn

Any help is much appreciated

This looks like you have a concept that does not have a name or fully specified name. Can you cross check for the concepts on this form?