I Can't access openmrs at locahost

Hello Devs, I am having a problem accessing openmrs at localhost: I have tried to google it up but don’t seem to find a solution. What could be the problem, i need your help. This is the error I’m getting. https://pastebin.com/A0LBVqSA

Thank you.

also facing the same problem

From the logs, it appears like you’ve deployed some module with the MyhelloworldController that is causing it to fail to start causing the entire application not to start.

why could deploying a module cause it to fail starting? I need guidance. how this be corrected, I has given me a lot of headache and am not progressing.

@wyclif what could be the solution?

The problem lies here org.springframework.beans.factory.BeanCreationException: Error creating bean with name ‘org.springframework.web.servlet.mvc.annotation.DefaultAnnotationHandlerMapping#0’ defined in URL [jar:file:/C:/Users/IRENE/openmrs/serveri/.openmrs-lib-cache/atlas/atlas.jar!/webModuleApplicationContext.xml]: Initialization of bean failed; nested exception is java.lang.IllegalStateException: Cannot map handler ‘${rootrootArtifactid}.MyhelloworldController’ to URL path [/module/${rootArtifactid}/${rootArtifactid}.form]: There is already handler of type [class org.openmrs.module.basicexample.web.controller.BasicexampleController] mapped.

Try removing the class BasicexampleController or map you controller MyhelloworldController to something else

Thanks @ningosi how do i do that ?

Can I look at your code? can you share that on github so that I can have a look?

@ningosi i tried the procedure didn’t work. I decided to delete the entire server and begin a fresh but still the server can’t run. I need help

@ningosi sorted

1 Like