HTTP Status 500 – Internal Server Error

Hi friends, Am running an SDK instance with a purpose of watching a module am working on. When I start my server with mvn openmrs-sdk:run command everything runs pretty well but when I search for the http://localhost:8080/openmrs/ i run into this error https://pastebin.com/gvccZySn. What could be the cause of this and the possible solution?

Thanks in advance.

1 Like

I’d suggest you follow this link here, and in the installation you can find the required settings.

Creating a server to run the OpenMRS platform or a distribution

Thanks for your prompt response! The error occurs when running a server which was running pretty well before. However, I have created a new sdk server but still running in the same error.

Which openmrsVersion are you running

Am running OpenMRS SDK 3.13 . 6 and Reference Application 2.10.0 on Platform 2.3.0

According to the logs you provided, it seems the server didnot run successfull, so am little confused, kindly stop the server and try again.

These are the logs https://pastebin.com/19zsnxVQ when I run mvn openmrs-sdk:run and this is the output on the browser https://pastebin.com/BN8WPDRy. Am running a server which I successfully build sometime back and has been running successfully not the one I created today.

Thanks Now the problem is that you are trying to access the server of different port numbers, Try changing your port to localhost:8080 which is by default.or else you can try access using your port in the runtime property but thats not advisable though it will work for you if you configure them very well

Thanks so much I had not realized. I have tried running it on port 8080 but still getting the same error.

Share the full log after you have configured your port tp run on 8080

Just a moment! am just creating a new server I will share the output when its done.

1 Like

@sharif After creating a new server I opted to run it on the sdk selected port which is 2 other than 8080 just to take an advantage of this fixed issue and am glad it run successfully on the localhost. However, am not happy since I have run away from an error which would have helped me learn something new.

good evening @jwnasambu , i ran into the same problem while i wanted to watch changes i had made. I tried reading through this thread for help but didn’t see any. I would like to know if any solutions were got after this?

Oh sorry for the error. @reganmakanga I should admit my original post wasn’t descriptive and for that case I don’t have correct answer however, the HTTP status 500 - Internal Server Error is caused by various reasons as reflected on this link which may help in troubleshooting process.

1 Like

thank you for this link. i tried running the server again with an β€˜n’ response when asked whether to update module to 1.8.5 snapshot from 1.8.4 and it ran fine though that was on a new server. the first server failed completely. i will check the link for further knowledge. thank you