How to switch languages in OpenMRS

I’m running the ref app 2.13 and it looks like I can’t change my language.

There is a mix of both French and English. My PC is set in French but even if I try to set my user’s default language to English, UI is still in French.

When I go to the legacy admin section, I can see my admin user language is set to english, but I don’t understand why everything still appears in French on the screen?


Strangely, if I set it to Spanish in the bottom page of legacy admin section, it seems to work better. There is still some parts in French but most of the app is now in Spanish. But it still not working if I set it to English (United Kingdom). Maybe I am missing the default locale_en file but I don’t know where the languages files are located.


1 Like

What value do you have for this setting on your system? Login

I added en_GB as the link/demo suggest, then I tried to switch between English UK and French but I still have the same problem. I’m wondering if my computer locale setting is set to French, maybe OpenMRS is using French since it is hosted on this PC. I have someone hosting the same OpenMRS version on an English computer and everything is fine when he’s switching language.

Include only the language character you need.

I tried en_GB only or en only and it still in French. I tried in Chrome, Edge, page translation is disabled, I also tried in private mode.

Here’s a look at another user. Language is set to English in her profile and everything is in French.

Maybe I’m missing some language packs in my OpenMRS installation?

Are you able to share the server side log via