How to set value to obs when creating an encounter

Hello, I am developping on the old version of OpenMRS 1.9.11 and Rest web service OMOD 2.25 for some project and I am having issue when attempting to create an encounter.

I can create the encounter if I don’t enter a value in groupMembers but what I wan is to enter some value to my groupMembers. Could you let me know what is the correct value forma that I should be passing?

This is my code and I am using Postman

And this is the error I got:

Thanks for your help.

Hello @anatoleabe, can you use pastebin , to paste your data content and also the error logs??

Hello @mozzy, thanks for your advice. I did it. Can you help me please? or do you know some one who can help me?

What is the Datatype of the concept whose value you are trying to set? That is the concept with uuid 3cd9b05c-26fe-102b-80cb-0017a47871b2

@anatoleabe the concept class for the concept of the parent obs should be a set , and then the concept for the GroupMember your trying to add ,should be one of the concepts in the concept set of the parent obs.

in other words the parent obs should have a concept that have a set of concepts

@dkayiwa This is the Datatype:

@anatoleabe does that concept contain a set of concepts?

Yes @mozzy, this concept contain a set of concepts. I want to set one of them HIV VIRAL LOAD.

Your uuid does not match with the one i asked.

Yes, it is the Datatype you asked. This is the whole with father

You are setting a value of “7” to concept of datatype “N/A” which is not allowed. I would have expected the concept datatype to be something like “Numeric”

I understand. But On this screen I see Numeric type and this is the field I wan to set up. May be I am not doing what is expected.

Hello @mozzy, by reading again and again your comment, I understood my mistake and I think I found the solution as you can see here:

I put the parent concept in the obs, then in the groupMember I put the concept that is the one of parent concept set and I can now set the value as I want.

Thank you very much @dkayiwa and @mozzy for your help.