How to fix "Failed to load Activator" error...?

I am new to OpenMRS, i tried to install the “Custom Branding” module but faced the error.

Error while trying to start module Unable to load/find moduleActivator: ‘org.openmrs.module.custombranding.CustomBrandingActivator’ Module: Custom Branding

can anyone suggest me the solution for this error…?

@dhanapatyaalsysdotco give details at pastebin.com if you don’t mind and folks here will help you out including the openmrs -api /module version details…

i am using OpenMRS 2.2.0 and the custom branding module of version 0.2

@dhanapatyaalsysdotco k then give us a detailed log at pastebin.com perharps we may see what went wrong

Could you be more specific about log details…i have found log files of jetty web server. i am integrating the modules through OpenMRS UI as Super User and its throwing this “unable to load activactor” error.

@dhanapatyaalsysdotco copy the whole log/stack trace and paste it here but it would make work cleaner if you pasted at pastebin.com then paste the link here…pastebin,com is tool for harbouring pastes for such purposes to ease diagnosis.

for example you can see a replica of my maven version here https://pastebin.com/Rqk5chYy you can see everything i did at command line and the result so copy your whole log from jetty web server and paste it at pastebin.com then give me the link

Thanks for your guidance,here is the pastebin.com link for your reference https://pastebin.com/EWyNM7Zb

@dhanapatyaalsysdotco have you looked at https://modules.openmrs.org/#/show/25/custombranding , have you tried to run Custom Branding module on platform 1.5.0.7125 down from 2.2.0 like you said?

it looks like the module creator has designated it to 1.5.0.7125 rather than 2.2.0 !!

i didn’t tried with 1.5 version, i will try that and check it and is there any way to make it compact-able with 2.2.0 version. I had encountered this error for some other modules too…

i downloaded from this site only, https://modules.openmrs.org/#/show/25/custombranding

@dhanapatyaalsysdotco that’s alright,it’s usaully wise to check version compatibilities before installing,and in case there’s more trouble or you need to add a new feature you can create a Ticket and devs can take it on