How to avoid notifications of own Talk posts?

When I send an email, talk will parse the message, create the topic, and send it back to me.

It’s pretty annoying. Is there any configuration to prevent that?

To confirm, are you only seeing this when you send email to reply to a topic or create a new topic? If so, I don’t think there’s currently any way to differentiate that yet. I will keep researching.

You could probably create an email filter to auto delete notification mail that is sent “From” your name.

If you’re also getting them when you post via the web, make sure to check the box “Do not suppress email notifications when I am active on the site” in the preferences menu.

I usually create new topics from Talk itself - to make sure I set the correct category.

But we usually reply much more often than create new topics, and I use email to reply. What happens is that gmail keeps my sent email, and within a couple a minutes I see ‘oh, there’s a new answer to that thread!’ and it’s just talk giving me back the same message I’ve just sent.

So I’d like one option like ‘When I reply using email, don’t send this message again to me’.

In your user preferences, is “Send me an email for every new post (unless I mute the topic or category)” checked or unchecked?


I believe it was unchecked, but then I wasn’t receiving all threads on my email.

So there was a design decision that checking that option would opt people in to receiving their own posts too. (I don’t agree with it, but it was debated…)

In theory, if you were to disable that option, then go into each category at and set it to “Watching” in the upper right, then you should get notified for posts in each category, but not your own. No guarantees though because I haven’t tried this myself. :smile:

For me I also was missing some emails until I turned on the Notify For All feature. Since then I haven’t noticed that I missed any emails but it has that undesired side effect of sending me my own replies also.

Same here! :slight_smile: