How do you completely uninstall an OpenMRS version?

I mistakenly installed OpenMRS 2.0.5. I then deleted the folder (files and database no longer exist on my system), however when I try to install ANY other version, after install I am greeted with this:

OpenMRS Platform 2.0.5.9f9213 Running!

If you are seeing this page, it means that the OpenMRS Platform is running successfully, but no user interface module is installed. Learn about the available User Interface Modules

How do I get 2.0.5 out of my system? I did some file searches but I cannot find where this might be installed on my system.

@lcascio I may not clearly understand ,but have you tried clearing the tomcat cache.Chances are that the system may be bootstrapping from the cache.So try clearing it and restarting the system.

In Linux there is a .Openmrs folder created which is a hidden folder. you also need to delete this.

1 Like

infact to get it try running this command " ls -a " it will show you all hidden folders…

This is installed on a Windows server not on a LINUX server. I realize the application is actually some kind of VM that is running LINUX.

To install:

  1. I just take the contents of the zip file for an OpenMRS version and copy them to a folder.
  2. I then double-click on the “openmrs-standalone.jar” and this “installs” the application (including making a “database” sub folder),

I’m assuming to uninstall the application I need only delete the folder where put the zip file in step 1, which I’m assuming deletes the VM, Tomcat and all. Is Tomcat actually installed somewhere on the Windows host I’m running this on?

I guess I could try restarting the Windows host system.

@lcascio did you try the two options we provided above? i.e clearing your cache and completely deleting your folders,plus go to your browser and clear cache and browsing history if you don’t need the history,then restart the machine…

I had tried clearing browser cache and history but that by itself didn’t work. I just uninstalled 2.6.1 again (ie. deleted the folder), cleared all the browser cache and history, AND rebooted this time. Will re-install 2.6.1 ref app and see if it attempts to load the 2.6.1 front-end vs the 2.0.5 front-end.

No luck. Ran the install for 2.6.1 reference app standalone as was greeted again with “OpenMRS Platform 2.0.5.9f9213 Running!”

I guess I need to look at the registry or something. Dumfounded how to get 2.0.5 off of my machine, what a terrible mistake it was to install that!

Is anything installed to Program Files or Program Files(x86)?

This was in fact a browser cache problem. When I initially cleared the browser cache in Chrome, I wasn’t careful about the history time frame to remove the cache, Chrome (recently installed) defaults to the past hour initially which left the 2.0.5 links in cache I believe. I deleted history for all time and I am getting the proper 2.6.1 ref app standalone UI now.

Thanks for the help and responses!

2 Likes

Hello @lcascio, Am actually finding a similar problem. Could u please drop mi a link for the latest version of openmrs such that i can try following your steps. Thanks😊

@lgilbert you can try this out http://openmrs.org/download/

1 Like

@lgilbert Apologies for getting back late on this!

I believe this was a problem with my browser history cache. I can’t say with 100% certainly since I did not repeatedly recreate the problem and then solve it. But the problem disappeared after I went into my Chrome browser and deleted all history.

I had done this originally to no effect but that was because I wasn’t careful on the history delete time range option - Chrome defaults to deleting just the last hour of browsing history. Once I selected to delete all history, launching the browser brought up the expected UI.

I would try this in whatever browser you are using.

1 Like

Thank you @tendomart and @lcascio , i actually downloaded the .omod files and installed them into the openMRS modules folder (legacyui in particular) and it worked for me.

1 Like

@lgilbert Good to hear that .

1 Like