How do I install an OpenMRS add-on?

openhmis
standalone
Tags: #<Tag:0x00007f88d03cdb00> #<Tag:0x00007f88d03cd830>

(mona saleh) #1

Hi, I need to install this add-on to the openMRS standalone reference application, but do not know how to install the add-on. Any help plz?


(Wesley Brown) #2

Hello @monasaleh! I am from the team that created the OpenHMIS Inventory module and can point you in the right direction to get started (I hope!).

The general instructions for installing modules into OpenMRS can be found here. Then the specific installation steps for installing the OpenHMIS Inventory module can be found here. Feel free to ask any questions you that you have about the module!

cc @whiscard


(mona saleh) #3

Hello @ibewes , where can I find the (manage modules) page?


(mona saleh) #4

I found it, then I chose to upload the module and I searched for the module to add it and had the following errors.


(mona saleh) #5

when I clicked for details, I got the following error:


(Suthagar Kailayapathy) #6

Didn’t you have any changes of using Manage Modules icon in the home page (it’s actually a part of SysAdmin OWA)? From it, you can directly search it and install into your system. Actually it requires some other modules also, you can simply go through it by our updated Module Management page (otherwise you need to install those missing dependencies)


(Wesley Brown) #7

I guess I’ve been out of the OpenMRS loop for a while because I didn’t even know about that Manage Modules feature!

@monasaleh As Suthagar mentioned, you will need to install the other required modules to start up the Inventory module. The specific modules that are required are mentioned in the Inventory module installation steps I linked above.


(mona saleh) #8

I installed OpenHMIS Cashier Module , and openhmis.backboneforms 2.3, openhmis.commons 3.0, jasperreport 1.5.6 modules, but I still get the same error. I tried upgrade rather than load module and still got the same error. Any thoughts on what I may be missing?


(mona saleh) #9

I tried a different path, I chose system administration, then manage modules, then got an error.


(mona saleh) #10

I tried to load the (form entry module), but got the error (Module formentryapp has been stopped)!


(Jeremy Ogembo) #11

Hi @monasaleh, what version of openmrs standalone are you using? I normally use the following path:

System Administration -> Advanced Administration -> Manage Modules -> Add Module

I would suggest you start with a new instance of the standalone and use the above process.

To get the Inventory module to work, you’ll need to install the dependencies in this order:

commons

backboneforms

jasper

inventory

cashier


(mona saleh) #12

Thanks a lot. It loaded and started successfully :slight_smile:


(Jeremy Ogembo) #13

Nice, thanks for the feedback. Please let us know if you encounter any issues.