How can I use SNOMED CT with Reference App 2.2?

I am trying to import SNOMED CT to my 2.2 installation . But I could not find where to do this. I appreciate any help in this regards.

What are you trying to do … We normally use CIEL dictionary referenced to SNOMED

I would agree with Judy. There is very little reason to import SNOMED directly for the purpose of clinical documentation in OpenMRS. CIEL is an interface terminology to SNOMED. You can use SNOMED in the reference tables to provide subsumption queries and other reference maps, and there was a GSOC student project which built some tools to do that. @darius might be able to help point you to that.

1 Like

Thaks very much Do we have any document that explains the process @judy @akanter I tried to expore concepts fom here but it does not work. There is an error message @darius is there any better way? Thanks again

In 2013, an intern built a Concept Management Apps module, which is documented at (I was the mentor.)

We worked on an ability to import mappings from the SNOMED CT, and this is mentioned in the documentation. I don’t actually remember whether we finished that function though. You’d have to test and see.

@yadamz, the suggested future path is to use the OCL Subscription module. This is still being built, so I don’t know if you can actually use it yet. (@raff can comment.)

Write to @akanter to give you access to the CIEL dictionary

hello again @judy @darius @akanter
So I have access to the dropbox with the database files. I imported the 1.11.1 sql file . after that it really slowed down my server. Is there a specific software or hardware requirements that will help improve the system performance. I am using Windows server and Tomcat 6

Thanks again

When you first download and load the dictionary it has to recreate the search index which may be taking some time. We have not characterized this. In prior versions, we sent the index with the file. @Darius, perhaps we need to look at how to do this will 1.10+ as well.