hibernate "NOsuch method error"

i have added a service class to my module, added a table to the database using LIquibase,configured the hibernete.xml file and the module applicationcontext.xml file . but when i i try to run the module link from administration page , it gives me the following error


and here is my module on it hub myFacelist_module

. i have tried to google , one of the suggested cause was about the spring and hibernate version incompatibility.

@dkayiwa @tendomart @wyclif @ssmusoke @k.joseph

Did you get a chance to look at this? https://wiki.openmrs.org/display/docs/Supporting+Platform+2.0+and+below

1 Like

thx @dkayiwa… let me surely look at it

but am still confused on how to use the Dbsession class in my DAO. Do i have first have to copy the whole Dbsession class code into my project… and that woud also ,mean copying the DBsessionFactory class code? .

yet wen i copy the whole DbsessionFactory class code , it returns errors :thinking:

ive failed to configure how to use the db session :persevere:

If you find the DbSession option to be complicated, then you may just do this: https://github.com/openmrs/openmrs-module-xforms/commit/5d79f327d27777a40ec755a90433e4dc69067e4a

1 Like

Thank u sir , i finally solved t. my problem was that , eventhe openmrs-api my module was using doesnt contain the hibernate-compatibility source code as most of the references in that document. so i had to first include the hibernate-compatibility module to be able to use the DbSessionFactory class

1 Like

Exactly what I was looking for :rofl:

Thanks again @dkayiwa and @mozzy

1 Like

oops , i even had forgotten about some of these posts i used to make :smiley: