"Help People Upgrade to Platform 2.x" Sprint Announcement

@ningosi see comments on the thread, we are using all the mentioned modules with 2.x u may just need to upgrade to snapshots in some cases, getting them released should not be a show stopper

1 Like

The first error I get when upgrading my 1.11.5 to 2.1.2, anyone else getting that? and we earlier had a discussion about that here Platform upgrade

  1. Can you try to upgrade from 1.11.5 to 2.0.6 first to Ref App 2.7.0 first

  2. Then you can change core to 2.1.2

Can you paste that section of the log at pastebin.com?

here it is https://pastebin.com/HDiizpud

This looked familiar and I found this thread that appeared to be related:

I think there may have been a more recent thread around this, but I can’t find it. @darius @mseaton does this ring any bells?

(We did not run into this issue during our upgrade, fwiw…)

I believe that I created an issue for this already based on Nicholas’s earlier feedback: https://issues.openmrs.org/browse/TRUNK-5383

And here is the thread: Platform upgrade

My personal opinion is that we should solve this in openmrs-core, and not require people to take the manual steps.

Thanks @darius that was the thread I was thinking off and couldn’t find.

I have added a sprint board: https://issues.openmrs.org/secure/RapidBoard.jspa?rapidView=160&view=detail

Please share some updates, as well as also picking up those tickets! https://issues.openmrs.org/browse/RCM-106 is a high priority one.

1 Like

That changeset is in 2.0.5, so I took the manual way of dropping that constraint and I was able to upgrade my 1.11.5 database to 2.0.5. The problem occurred when I tried to restore the constraint back, this is the error

@ningosi the “error” link you gave is a link to stack overflow. Can you please share a link to your actual error?

@ningosi, @valvijo, since we’re a week into this sprint, could you all give an update on how upgrading is going?

@ggomez does any of your team wanna join this sprint?

i have upgraded formfiletr moduleto run on 2.0.5 and it runs succesfull . it has also run succsefully on 2.1.3

https://github.com/openmrs/openmrs-module-formfilter/pull/1

This image shows what is left after manually dropping the constarint

. And to restore it I tried writing this and got this error ERROR 1215 (HY000): Cannot add foreign key constraint . I get the same error when I write this, and that is why I ended up checking online for explanation and that is why I landed on stack overflow

So far I have been able to upgrade my 1.11.5 database to 2.0.5 platform(though by manually disabling the constraints on reporting table), some of the community modules that had issues earlier are running - I needed to upgrade them to the newest versions(database backup and patient flags), some of them are in snapshot version(they may need to be released), I have seen @mozzy has a fix for the form filter module to run on 2.x which will need to released and merged for testing. a blocker is to restore the earlier disabled constraints, Some of our modules are NOT compatible(We will need to fix them to run on 2.x). I appreciate the help from the community to make it success.

I notice that the constraint name you’re trying to add has been replaced by something newer in the reporting module.

You might also try creating an index first, i.e. try to replicate these two liquibase changesets:

1 Like

So I did the following; I dropped the old index created on that table from the database, dropped the changeset in the liquibasechangelog table, stopped and restarted reporting module. The index got recreated with the correct name. I ended up writing this changeset to effect the foreign key constraint on the index created and resulted into the same error when trying to upload the change

Thanks to @tendomart and @mozzy for taking care of the Patient Flags and Form Filter modules!

Still open for work is RCM-106 (Cohort Builder not working on Platform 2.1+), which is an important bug to fix, for implementations beyond eSaude. (@ssmusoke perhaps there’s a UgandaEMR-focused dev who might look at this, to ensure you all would be able to upgrade from 2.0.x to 2.1.x?)

@ningosi can you document steps that someone else could take to reproduce this issue using the SDK? That might help someone help you. E.g. it could be to use the SDK to create a server with RefApp 2.4 (which is on platform 1.11.6), then explain how to save a cohort definition through the UI, then to upgrade to the latest RefApp release. (I’d document this on TRUNK-5383)

2 Likes

the Filter Module runs loads properly but wen i click on a single form …it brings this error https://hastebin.com/obukokiheb.swift. any clue on how i ca go about it?