Help I'm stuck! Build failure with mvn clean install using java "1.8.0_333" (now)

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.10.1:compile (default-compile) on project openmrs-api: Compilation failure [ERROR] /Users/admin/git/openmrs-core/api/src/main/java/org/openmrs/module/[17,27] package java.rmi.activation does not exist

Most likely, you are using Java 11+ with a version of OpenMRS prior to 2.5.0. Most likely your issue will go away if you build it with Java 8.

Thanks, Ian you were correct about not being on java8. I made the adjustment but unfortunately, that did not resolve the issue. The build still fails with the error message java:[17,27] package java.rmi.activation does not exist

@gsa13 Would you kindly paste the whole log at and drop the link here?

I’m 85% sure this is the proper link…

What’s the output of this command mvn -v?

mvn -v

@gsa13 sorry brother. kindly go to your command line and run mvn -v to see the maven version installed on your computer or otherwise read through . 4

Thank you for the link to read. The results running mvn -v

Apache Maven 3.8.6 (84538c9988a25aec085021c365c560670ad80f63) Maven home: /opt/homebrew/Cellar/maven/3.8.6/libexec Java version: 1.8.0_333, vendor: Oracle Corporation, runtime: /Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home Default locale: en_US, platform encoding: UTF-8 OS name: “mac os x”, version: “12.5.1”, arch: “x86_64”, family: “mac”

Hi Mumbere, I appreciate the link as it also included step-by-step directions on installing OpenMRS for Mac OS. I have tried all I can think of to get past the build fail including starting from scratch and installing from the terminal without using eclipse. Do you know of any other resources I can lean on for help?

Sorry about that persisting challenge brother. let @jwnasambu help us. thank you

Try running these commands: git reset --hard and git clean -df then compile again

I appreciate it but I’m still getting the same error.

Share the output of the commands

java -version


javac -version

java version “1.8.0_333”


javac 1.8.0_333

Try to run git pull --rebase upstream master and compile again

So I’ve finally made it to the OpenMRS Core 2.6.0-0 Installation Wizard using docker and immediately ran into an issue with my Mysql password required for login. I reset the root Mysql password ​(though I knew what it was) ​and reset everything and I continued getting the error:​"Unable to create the database. The password might be incorrect or the database is not started."

I’m running mysql Ver 8.0.30

I’ve seen in other threads stating the​ Solution is to select advanced settings and you will have the option to change the default password. This did NOT work for me.

Thanks in advance for any insight.